External monitor not detected by the NVIDIA Quadro K3100M video card


I am installing OpenSUSE 13.1 / KDE on a brand-new MSI GT70 2OK laptop, equipped with an NVIDIA Quadro K3100M video card. The laptop is intended to be connected to an external monitor for doing 3D graphics. More on the config:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK104GLM [Quadro K3100M] (rev a1)

**PROBLEM: On OpenSUSE, the external monitor is not detected at all **(= no signal) neither on DisplayPort nor on HDMI port. Whereas on Windows 7, the external monitor is detected and works on both ports.

This is at least the status when using the ‘nouveau’ driver, whether booting on fresh install or recovery mode.

So of course my hope is that installing the NVIDIA proprietary driver will fix this. Since the Quadro drivers are not available on the NVIDIA OpenSUSE repository, I followed the “hard way” installation instructions below:
http://en.opensuse.org/SDB:NVIDIA_the_hard_way (out-of-date but still helpful)
http://monsterbeee.blogspot.fr/2013/12/my-notes-manually-install-proprietary.html (works well, thanks MonsterBe !)

Install changes in brief:

  • in /etc/sysconfig/kernel: NO_KMS_IN_INITRD=“yes”
  • in /etc/modprobe.d/50-blacklist.conf: blacklist nouveau
  • in /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT="… nomodeset"
  • in /etc/X11/xorg.conf section Device: “Device0”, “nvidia”, “NVIDIA Corporation”
  • latest NVIDIA driver (331.67 64-bit) correctly installed (according to the NVIDIA installer)

When I boot now, the startup progress is displayed, and then stopped, with a black screen displaying one single line of text (above the log-in prompt):
[FONT=courier new]
usb 3-11: string descriptor 0 malformed (err = -61), defaulting to t[/FONT]

I guess this error is not the fatal one since it is reported anyway when successfully booting in recovery mode. The actual fatal error seems logged in Xorg.0.log:

14.621] (II) LoadModule: "glx"
14.621] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
15.371] (II) Module glx: vendor="NVIDIA Corporation"
15.371]     compiled for 4.0.2, module version = 1.0.0
15.371]     Module class: X.Org Server Extension
15.371] (II) NVIDIA GLX Module  331.67  Fri Apr  4 11:43:47 PDT 2014
15.374] Loading extension GLX
15.374] (II) LoadModule: "nvidia"
15.374] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
15.428] (II) Module nvidia: vendor="NVIDIA Corporation"
15.428]     compiled for 4.0.2, module version = 1.0.0
15.428]     Module class: X.Org Video Driver
15.436] (II) NVIDIA dlloader X Driver  331.67  Fri Apr  4 11:24:40 PDT 2014
15.436] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
15.436] (++) using VT number 7

** 15.436] (EE) No devices detected.**
15.436] (EE)
Fatal server error:
15.436] (EE) no screens found(EE)
15.436] (EE)

“No devices detected”… what should I do now :frowning: ? Thanks for your help, I am a Linux newbie!

Looks like you have an optimus machine Intel+NVIDIA

You will need bumblebee


Thanks ! I will first try this “Bumblebee the easy way”…


You tried to make your computer output readable by changing to a fixed font. That is very nice. But it will still be better when you copy/paste such text between CODE tags. You get them by clicking on the # button in the tool bar of the post editor.

Ok, sorry, that was my first post.

Oh yes, I saw that (btw, welcome!).

It is not a rebuke, no need to appologize. It is not very obvious to find this feature, thus we have to tell every first poster. That is how life is. :wink:

If all you want is to use the Nvidia card on an external monitor there is an alternative, an alternative that will give the full power of the Nvidia card, Bumblebee is rather slow as it has to do all the rendering via the Intel chip, those machines are wired that way. Now, I just tested the alternative, sorry haven’t had a HDMI cable until recently, but this is how I made it work.

First I uninstalled all bumblebee related, then I installed the Nvidia driver “the easy way”, i.e. I added the Nvidia repo in Yast and installed from Yast, the “hard way” should work just as good. I ran nvidia-xconfig and edited the file /etc/X11/xorg.conf, I added this line in the section “Device”

BusID    "PCI:01:00:0"

“PCI:01:00:0” is from your output of lspci.
Your system will boot grub on the laptops display and then switch over to your external display for login, that’s how my system works at least.

I installed Bumblebee the easy way (using Knurpht’s package), and although I can now enjoy a great laptop heat decrease, external monitors are still not detected :(. However I am not 100% sure yet that Bumblebee is correctly installed, because on my config Knurpht’s package did not perform all of what it claims to do (e.g. it installed the NVIDIA driver and created the service, but did not blacklist nouveau - I had to do it myself - and did not create any bumblebee group). I am awaiting Knurpht’s explanation on that.

If it turns out that my Bumblebee install is correct, then it will mean that Bumblebee does not fix the detection problem, and I will then try your technique :slight_smile: