ext4 external USB HD - No write permission?

Friends. Good day to you all !

I switched a external 500GB usb HD from FAT to ext4, because the box it’s on no longer has windows.

It mounts fine and I can read it - but not write.
I have some inkling as to what to do, but prefer your opinions first.

11.2, kde4.4 :wink:

Cannot write even as root? Is it mounted ro? Do you need to fsck it first to make sure that it’s clean? Did you try to recycle a FAT mount line in fstab?

I just formatted it in Parted. It should be clean.
I’m sure root will write to it, haven’t tried mind you. I’ll check in a min.

There is no and never was a fstab entry for this USB device. Are you suggesting there should be?

No, shouldn’t need one.

If it’s a Linux filesystem, then normal Linux permission rules apply to it, even though it’s physically external. So the top directory will be owned by root, and if you want users to write on the disk, the simplest way is to create subdirectories and chown to the user in question.

That is what I thought.

Added my user account to have write permission
Now it works fine;)

Thanks Ken

Honeestly, at least the gurus here should stop thinking that “internal” and “external” have any meaning to the OS.

I’m trying to think of what to say to that comment…

I wonder if I didn’t understand the point you make

or was I just adding clarity to my post…:\

You decide Henk.


I’m trying to think of what to say to that comment…[/QUOTE]
I was thinking the same.

Just WHO are the Guru’s here being refered to ?

I don’t consider myself a Guru. I know Linux Guru’s (who work at my office) and I definitely don’t hold a candle to them. Indeed, with no disrespect to our forum membership, but frankly speaking, most users on our forum don’t hold a candle to the Linux Guru’s I know.

In my case I consider myself an average user with a bit more experience than some of the other average users. But my basic lazy nature as a user, has meant I will always be an “average” user. Nothing more.

Does that quoted comment mean that “average users” with large post counts can’t post asking for help? And if they do ask for help they will be criticized for any help request, statement, or misconceptions, whether valid or not valid ? If so, then I belong to the wrong forum.

Again, you make it sound like no one here but you is qualified to help anyone here. Your attitude stinks. I already deleted my posts on another forum because of you and have not posted here for a few weeks for the same reason. You really don’t belong here. You do not fit in with the helpful friendly atmosphere of this community. >:(

Because I am lazy, I did not start to look for one or more of the posts I made in threads about people who blurred their problems by thinking that:
a) the system (that means kernel, the rest, DE) is aware if a disk is living inside or outside the case (called “internal” and “external”) (remember the pictures of the inside-out systems?)
b) the system (apart from the kernel using the correct driver for the correct interface) is aware if a disk is connected using ATA/SATA or USB or real SCSI.

Thus with all these talking about mounting (“automatic” or not), putting entries in /etc/fstab, those two factors are uninteresting. Only usage is important: do I want it mounted always on a fixed place (like / and /home and maybe more), do I want it mounted on connection while the system is running with a user loged in into the GUI (this usage goes often with the word “media”), or other.

In your problem there was talking of “external” (probably you wanted to say USB, but I am not sure), of former fs types on it (I can not believe that after creating ext4 on it anything of FAT would be there).

It was only a problem of how do I mount where. And that is about creating a mount point and setting it to the correct owner:group and giving it the correct permission bits. But you created a fog around it to yourself and others by talking about external, etc.

Now I know that it is done often here by a lot of people, who are still living in the times of MS-DOS and short thereafter systems, where a real disk (existing since the 60’s) is such a peculiar thing that it is called a hard disk. But I was realy disappointed that, having often written about this, this is still te case here with the gurus. :frowning:

Never mind, I will have to write this a few more times I think. In any case I will not chalenge you on zypper lr -d, fdisk -l, etc. You are hammering like I am. Often in vain, this is our fate. :’(

I don’t like where this is going and it’s not necessary too.

Could it be that Henk meant that there’s no difference for a linux system in handling a filesystem whether a disk is built-in or not? It’s basically the same ken_yap says.

@Wilson_Philips: wouldn’t you rather have things cleared ?

Edit: Henk posted himself in the meantime

While I was composing the answer to Carl above, I missed the two other posts in between.

Hm, it seems that I stirred up a lot. This was not my intention and I appoligize for that. What I did wrong imho was:

  1. my answer was and add on after the problem was solved, and not an answer to the problem, but that was not clear enough;
  2. I was a bit (well a lot) frustrated by the fact that after so much trying I still see mount problems agravated by the fact that non important facts are used to make a problem worse then it is, not so much for newbees, but for those who allready have seen a lot of those threads (loosely called gurus by me). And I showed that frustration.
  3. the emotions the word guru seems to call upon. It only means teacher (to the one who sees another one as such) andis often only tha case about a very small subject of knowledge. I do not know if I understand what others read from this word, but it has not much to do with post count (not an interesting phenomnon to me). Will try not to use it anymore.
  4. I am aware of the fact that not being face to face to the others in such a forum (and in fact in all sorts of “modern” types of communication can generate a lot of misunderstandings. This is agrevated by the fact that, how good the mastering of english looks, it still sin’t the first language of a lot of us. But I may not have given this enough thought.

Maybe I will not answer to “mount problem” threads for some time to come. Better for all of us.

Sorry, Knurpht. Not sure what you mean by cleared. :slight_smile:

I meant, wouldn’t you rather spend some time on a PM, have some interaction and see what the other person realy means. Clear the dark clouds from the sky?

Frankly speaking? No. I would rather see him gone. That’s how I feel. However, he is a mod and I am no longer one, so it will probably end up with me being banned. That is the way things work, and I understand that.

Closed to me then.

Enough already!

To add to the Fog, this is what I originally said:
I switched a external 500GB usb HD from FAT to ext4

I did know exactly what I was writing and @ken_yap had no problem deciphering it.

Do I understand how devices mount in openSUSE - YES.

Am I confused - NO.