expressvpn and opensuse

Greetings all,

Giving Tumbleweed a go again and as always very surprised at the progress. Installer look great, like the changes to yast :slight_smile:

Now the problem; tried installing expressvpn from the official rpm from their site. This file is actually for Fedora and I took a chance (sometimes they just work). It installed (after complaining the package is broken) but it won’t run complaining the service isn’t running (and trying to start it says no such service…

As the site is blocked and only accessible once I have a VPN running I am a bit stuck to get some info on what to do next. Anyone else got it to work or have any ideas?

nailed@linux-t5xx:~> expressvpn activate  
Cannot connect to expressvpnd daemon.

It seems the expressvpn daemon is not running. Please run "sudo service expressvpn resta
rt" to start it.

If the problem persists, please contact us.
 nailed@linux-t5xx:~> sudo service expressvpn restart   
[sudo] password for root:  
service: no such service expressvpn

Skimming the expressvpn documentation,
The following page is likely your best bet for success, choosing the “Other Linux” option.

In summary,
Generate your custom pvpn file on the ExpressVPN website, select the OpenVPN option and provide your sign-in credentials.

Use any console app except xterm.
Install openvpn
Run openvpn with the “–config” option as described, then drag and drop your custom ovpn file on the terminal window (I’ve never done this, so don’t know if this will work as described), which should automatically import your configuration settings.
Now, you should be able to just hit your “Enter” key and your openvpn should initiate a connection.
Leave the window open (can be minimized) until you want to terminate your connection, you should be able to hti CTL-C as described or simply close your openvpn console.

For any succeeding connections, just start with the “–config” step and repeat.

Without more info, I can’t know what the problem is with your Fedora package, my guess is it could be a hard-coded path in the configuration (a common coding mistake). I looked at the code as posted on github, and it looks generic enough to not have problems on openSUSE.

Without more testing I can’t be sure, but it’s also likely that you could create an openvpn connectionn in Network Manager, and import your ovpn file


Thanks for the reply and a possible solution… Will have to find an alternative method of getting on the site as I need a VPN to access VPN sites in my present location :frowning: