[exfat micro sd] transfer aborted due to error 5


I recently bought a sony handycam and took several data on a micro sd (64 Gb – sandisk type 10) I got delivered with it an adaptator, in standard SD format.
There is no way to directly send data from the handycam to the computer, so I used this adaptator on my laptop using the integrated SD slot.
As exfat was previously installed (exfat-utils, fuse-exfat) the volume was instantly mounted and I could transfer the files (MTS) BUT it seems that:

  • the copy will handle only one file, the second is each time I tried aborted with error 5. The volume is in a unmounted state after this error.
  • I have to reboot the laptop each time I want to copy one more MTS file to the local harddisk. The size of the files are between 100Mo to 400Mo.

I did not tried with standard SD because I couldn’t find my old camera… it’s somewhere but I can’t put my hands on for now.

I don’t know if this is linked to the adaptator, the sd ram slot driver, or exfat driver…

It happened with root user, non root users.

I can copy only one file then reboot and copy another one… if there is no reboot the adaptator is not recognized, even if I plug out and plug in the card… nothing happens.

I can’t mount manually the adaptator (and so the micro sd card) because fdisk -l never retreive any entry different than the partitions on main harddisk :{

Any idea ? (it worked good with the same adaptator and card with LEAP).

How did you copy your files, using a file manager or command line? If you did it one way, did you try the other?

If you used a file manager, which one did you use?


Greetings TSU…

Effectively I did not dig very far concerning this issue…

I did those steps:

inserted the micro sd into the adaptator
inserted the sd card into the computer
opened the card reader using dolphin
getting the folder where files are in, STREAM
select the whole *.MTS files
try to copy to a local drive with enough space and access rights

the first file is always copied without any problem, but then one file is copied I got “cannot copy file” (errno: 5) error.

Then the card is unmounted and to get it “remounted” I got to reboot the computer… fdisk -l tells nothing concerning the card that is still in the slot.
The restart seems a lot slower then normal (maybe some descriptors/locks have to be freed)

Using terminal:

I first did fdisk -l
mount /dev/cmm******* /mounted
I did cp /mounted/…/*.MTS /root/Vidéos/clips

I got I/O error after the first file copied…

When mounting the mountd warned the volume wasn’t cleanly umounted… that’s normal I did not check anything but rebooted straight after the dolphin test.