eth0 not working

Hi, I’m using 11.3 gnome and cannot fix the eth0 connection. Tried to make it work with connection manager, ifup but both of them did’n make eth0 work. Here are some logs that you might wanna see:

Module Size Used by nls_utf8 1165 1 st -

eth0 Link encap:Ethernet HWaddr 1C:6F:65:47:03:16 UP BROADCAS -

ifdown eth0:
eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express -

ifup eth0:
eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express -

I have TP-LINK router that sends wireless signal through the house which I’m using on my laptop’s Ubuntu to connect on the internet, also I can connect with Ubuntu from laptop via the same cable that I’m trying to use on my desktop, so the router and cable are working. Also on my dekstop I’ve installed Windows 7 and can’t connect from there either. The computer is new so i doubt that there is something wrong with its hardware. It all started when my connection disappeared. My ISP advised me to reset my router by plugging out the power cable and plugging it back in after 5min, and so I did. After that I could connect only from laptop. Tried to reinstall suse, to install ubuntu, but nothing worked. When I installed suse on my friend’s computer, the only thing that I had to do is to open YaST and change the Network setup method from ifup to the NetworkManager, and also insert the MAC adress in the connection’s properties. Tried that on my computer, but also didn’t work. Does anybody have a clue on what’s going on here?

Have a look at this thread-- That was in april 2011 so it’s contemporary. Seems a driver from the manufacturer was required. But let’s see what others say also.

Also, reading this through suggests manufacturer’s drivers Gentoo Forums :: View topic - Realtek 8168B: Which driver? In kernel or Realtek’s?