/etc/inittab in Leap 42.1

I just installed OpenSuSE Leap 42.1 on my computer, due to the missing driver of the Nvidia VGA card, I have to boot the computer in text mode and download and install the VGA driver from Nvidia web site, after these steps, how to configure the system to boot in graphic mode?

OpenSuSE 13.1 and older version has file /etc/inittab to set the level 5
id:3:initdefault: for text mode
id:5:initdefault: for graphic mode

Thanks for helps
Jyh-Shyong Ho

YaST > System > Services Manager. The Default System Target can be set at top left.

You shouldn’t have to do anything other than reboot your machine. If you’ve installed your nvidia driver, it should by right boot graphically. If I’m wrong, maybe someone more knowledgeable might chime in.

Hi there, I would like to do the opposite, to start the system in text mode. I did so many changes but the Leap still starting in graphic mode. How can I set up to start in text mode? In “Services Manager” I can’t see any text option and also I have added “level 3” in the Boot Loader and again, no changes.

Thanks for any help.

From the command line as root user use systemctl command;

(Runlevel 3 / init 3)
systemctl set-default multi-user.target

(Runlevel 5 / init 5)
systemctl set-default graphical.target