ERST not supported

My HP Microserver Gen 7 (model N54L) has been running OpenSuse for several years. A few days ago I had a boot disk failure. I replaced the boot disk and installed Tumbleweed from scratch. The installation appeared to succeed but when I removed the installation media and rebooted the system hung displaying an error message “Failed to get Error Log Address Range”. I tried using Leap 42.3 and got the same error message.

Google took me to a post from HP about a later model that has a fix, an update to the BIOS.

http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0109228

Is it possible to get around the problem that the hardware does not support the ERST feature?

As far as I can tell the message is purely informational; it simply means that kernel won’t use persistent error log. Do you have other problems?

Anyway, you should be able to disable ERST initialization with erst_disable=1 kernel parameter.

  1. Have you installed all the available HP software for your machine? This should be a SOP for all new machines, particularly from major OEM vendors like HP. Scroll down to the SUSE 12 packages. Maybe the BIOS upgrade will be offered in the HP System Management package (after it scans your system).

http://h20564.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=6525483&swLangOid=8

  1. Otherwise, the Win2008 and later downloads from the above page show a BIOS upgrade is available but only with a support contract. To install, you’d either have to install a Win long enough to run the BIOS install or extract and run from a console.

If the machine is doing important work for you, IMO the BIOS firmware upgrade is likely worth whatever it costs, or use some other hardware.

TSU