Error while creating new user

I want to create a new user so I can clean out old user home directory - I do this approximately every six months (find it’s the best way to unwanted relics etc).
The problem this time is I get an error, after the user is created, while trying to create the new home directory.
ERROR: Cannot create home directory /home/username. Parent directory is not a Btrfs volume.
I use ext4, not Btrfs.
I use Opensuse 15.1(beta)
If anyone can assist with this problem, it would be appreciated.

How exactly are you doing this? Is /home on it’s own partition? Is home mounted when you attempt this?

Everything normal here with full ext4 install, both creating a new user with existing home folder (offers to change owner) and creating a new home for another username.
A better description of what you exactly did may help us understand what happened on your system.

I tested this process the normal method. I’m using 15.1 Beta vith ext4 also.

Step: go to Yast ==> Security and Users ==> user and group management ==> Add a new user named Fred

That worked fine for me, logged out of my John person and logged into my new Fred. I’m not sure what that means for you except that it’s not failing for everyone.

[you did use the correct method like this too?]

And how exactly are you trying to create new home directory? For that matter, how exactly are you trying to create new user? There are multiple ways to do it.

I am slso using opensuse 15.1 with an ext4 partition. I tried setting up a new user with yast and this worked fine.

It might be worth doing a system update (zypper dup) and and have another go, using yast, to set up a new user.

  1. I tried with yast adduser.
  2. Logged as root and tried again.
  3. Did a soft install - only formatted system folders.
  4. Did a hard install - deleted partitions and rebuilt - this allowed me to create new user and home directory with user folders during the install. This did not allow me to create new user with yast. It did allow me to create from the command line with:
    useradd -g users -p pwd -d /home/user -m user
    This only has the bin folder(not a problem)
    I don’t know how this has come about - never had the problem in near 14 years - and in truth it is easily avoided, but I would like to know why if possible.

It might be worth doing a system update (zypper dup) and and have another go, using yast, to set up a new user.

The system update with zypper dup is one of my main initial setups after an install and/or normal update and I performed one prior to numbers one and two.

Hi all,
now 15.1 is released and the error is still there:
Fresh install from ISO.
Everything installed on a single partition with ext4.
System seems to run fine, initial user account which was created during installation works.
Then: Yast ==> Security and Users ==> user and group management ==> Add a new user.
Failure. (Error message is in German - but translated is says that the parent directory is not a Btrfs file system).
The message is “correct” - but I don’t see why it should be a problem that / and /home are on one ext4 partition?!?

The user is created (in /etc/passwd), but no user directory is created in /home.

Workaround:
Copy /etc/skel to /home/<username> and then change the user (chown -R <username>:users /home/<username>).
Then the user can log in and work…

Still - it is a bug (in yast?).
Is anyone aware of a bug report?
Is there a fix/solution - not just a workaround?

BGS

I decided to test this.

I did a clean install. Everything is in a single partition with “ext4” – except that there is also an EFI partition for UEFI booting, and a swap partition.

I pretty much took the defaults for everything. I chose the KDE desktop, and “ext4” for the file system (I used the “Guided setup” button in the partitioner for that). I set the local timezone. And I think everything else was default. Okay, I also had to setup the initial user account.

I should maybe add that I did this all in a KVM virtual machine, not on real hardware. I used the iso for the install (configured as a CD/DVD drive for the virtual machine).

Install went well. I then booted into the machine. I selected Yast from the menu, and went to “User and group management”.

I was able to setup a new user without any difficulty.

I am aware of one major difference between what you did and what I did (apart from using a VM). I installed with English, whereas you probably used German. So it is possible that this is a bug related to the translation.

My ability at German is too poor for me to try an install. So I guess I’ll leave it at that. Your ability at English is somewhat better, if you want to experiment with an English install.

Is anyone aware of a bug report?

You could create one. I am not aware of an existing bug report on this. But then I’m only a user.

Hi
There is one report of user having a USB yubikey present causing issue creating a new user…
https://lists.opensuse.org/opensuse-support/2019-05/msg00025.html

i can confirm the problem

fresh install of leap 15.1 kde onto an ext4 partition; when installation on real harware, add user with yast fails (“parent directory is not a btrfs volume”), and works when installation inside a virtualbox

“Me too” in this thread hardly helps. If someone really wants this to be fixed, bug report is needed.

I created a bug report:
https://bugzilla.opensuse.org/show_bug.cgi?id=1136776

Vote for this bug if you also encountered it.

That’s going to be marked as a duplicate.

I’m not sure of the conditions, since I have been unable to reproduce the problem. However, this bug has made it to the Most Annoying Bugs list for 15.1.

I am seeing also bugs 1136281, 1136719, 1134970. The last of those is private, so I cannot see any details.

I also created a bug report - it is now mentioned in https://en.opensuse.org/openSUSE:Most_annoying_bugs_15.1.

A new Version of yast2-users is in factory:
https://build.opensuse.org/package/view_file/openSUSE:Factory/yast2-users/yast2-users.changes?expand=1

Hello,

in case this is still relevant, I’m having the same problem. My /home is its own ext4 partition (a BIOS RAID), and when creating a new user (only default options selected), I get that same error message: “Cannot create home directory /home/newuser. Parent directory is not a Btrfs volume.”

Did not find a solution yet.

Have no idea where the bug is but it’s easily recreateable. For me, it depends on how I do an install. My scenarios are under VirtualBox running on leap15.0 host. The VMs do not have separate home directories. Format is ext4.
Guest network is set to wicked as opposed to NetWorkManager. both host and guest.

Scenario 1:
Install from ISO.
Decline the offer to add additional online repositories.
Complete installation, reboot, etc.
Run Zypper up.
Yast add user works as desired.
Interesting side note: The network connection (DHCP) is now defined as eth0 slaved to br0.

Scenario 2:
Install from ISO.
Accept offer to add additional online repositories.
Complete installation, reboot, etc.
Yast add user fails to create home directory as described above.
Interesting side note. The network connection is configure in the tradictional way. No br0