Error when running combustion script

The error


the combustion script:

#!/usr/bin/env sh

cp vconsole.conf /etc/vconsole.conf && chmod 644 /etc/vconsole.conf
rm /etc/localtime && ln -sf /usr/share/zoneinfo/Etc/UTC /etc/localtime
echo root:root | chpasswd

cp sshd_config /etc/ssh
mkdir -p /root/.ssh
echo <censored> >> /root/.ssh/authorized_keys

zypper dup -y
zypper in -y containerd
zypper in -y conntrack-tools
zypper in -y socat
zypper in -y ethtool
zypper addrepo https://download.opensuse.org/repositories/devel:kubic/openSUSE_Tumbleweed/devel:kubic.repo
zypper refresh
zypper install kubernetes1.29-kubeadm
zypper install kubernetes1.29-kubelet

mkdir -p /etc/modules-load.d

sudo tee /etc/modules-load.d/containerd.conf << EOF
overlay
br_netfilter
EOF

cat <<EOF | sudo tee /etc/modules-load.d/k8s.conf
overlay
br_netfilter
EOF

mkdir -p /etc/sysctl.d
cat <<EOF | sudo tee /etc/sysctl.d/k8s.conf
net.bridge.bridge-nf-call-iptables  = 1
net.bridge.bridge-nf-call-ip6tables = 1
net.ipv4.ip_forward                 = 1
EOF

systemctl enable containerd
systemctl enable kubelet
systemctl enable kubeadm

@Misekayek0l Use;

#!/bin/bash

# combustion: network
exec > >(exec tee -a /dev/tty0) 2>&1

Not #!/usr/bin/env sh

Whit is the exec thing?

@Misekayek0l first line is for the network, second copy the output to the tty.

Changed #!/usr/bin/env sh to #!/bin/bash and the error persists

And the other part for network?

What it is?

It will no terminate my script unless is in the end?

@Misekayek0l you need to have # combustion: network for the network to function. Yes, it will run the script and move on to finalize the install…

It worked. By the way how do make it to reboot to apply the kernel changes

@Misekayek0l not sure, but systemctl reboot should suffice.

But It would no longer execute the network bit or would not even be executed. (In the combustion script)

@Misekayek0l add a reboot service to run once after finished.

After which service it should run?

@Misekayek0l
Ref: https://rootco.de/2020-12-09-microos-pi-network-monitor/

[Unit]
Description=First Boot Reboot

[Service]
Type=oneshot
ExecStart=rm /etc/systemd/system/firstbootreboot.service
ExecStart=rm /etc/systemd/system/default.target.wants/firstbootreboot.service
ExecStart=systemctl reboot

[Install]
WantedBy=default.target

Add to combustion script

## Reboot after setup
cp firstbootreboot.service /etc/systemd/system/
systemctl enable firstbootreboot.service
1 Like

Now I am missing the kubeadm command

@Misekayek0l so in the output do you see it all (as in packages) getting installed? I normally do one zypper -vvv in ... command…

Where is the combustion output?

Found it, get here Combustion script fails to install kubernetes - #6 by Misekayek0l

Looks like my script needs network in an early stage of execution, thus I need another solution for network