Error No operating system

Several months ago I installed Suse on my box…setup a dual boot with Windows XP. By default it booted into Suse. The problem is that the company I work for, not a science company, is VERY windows-centric, so nearly everything I do is in windows. The IT people here periodically reboot the computers which creates a problem for me since I often work remotely and this results in my computer booting into Linux.

So, to fix the problem I went into Suse, opened Yast, and changed the default boot to windows, and restarted. Now it won’t boot into anything and not even the boot menu comes up.

I get the following message:

Error No operating system

Intel(R) Boot Agent GE v1.3.22
Copyright (C) 1997-2008, Intel Corporation

CLIENT MAC ADDR: 00 1C C0 E2 61 31 GUID: CAB279BC 5BF7 11DE 8A18 0007E9BECBF3

PXE-E53: No boot filename received

PXE-M0F: Exiting Intel Boot Agent.

Boot Failure
Press any key to continue

If I push any key, the same error repeats. Really, I truly couldn’t care less about the stuff I have on the Linux partition; however, the Windows partition has TONS of data and programs I’ve written that would be an enormous loss. Suggestions? I’m even open to reinstalling everything if I can just figure out a way to rescue the stuff from My Documents and a couple things on the Desktop…

All fixed.

First I tried repairing the system using install CD, but even though it said grub had been fixed, it still wouldn’t boot. So, since I didn’t need any of the data in the Linux partition I simply reinstalled Linux, included windows in the boot menu, set windows as the default, and everything works just fine now.

Yast2 stepped on your Grub it does that on some Suse installs. On your system when the system can’t find an operating system on the CD/DVD, Floppy, USB or HD it looks for a remote OS (PXE) to load on the network.

Read and try Swerdna’s grub repairs Portals, post any additional pre-repair questions :

GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

You have a Suse installation DVD/CD to boot for repairs?

perryridge wrote:
> So, to fix the problem I went into Suse, opened Yast, and changed the
> default boot to windows, and restarted.

apparently either you used YaST incorrectly or you discovered a very
nasty bug…i’d ask you to figure out which (i lean toward operator
error) and log a bug report if in fact you have one…

you will need to document the steps it takes to duplicate the affect
you found…maybe you can recall what you did where…

CAVEAT: [posted via NNTP w/openSUSE 10.3]