Error installing OpenSUSE 11.3 on Dell T3500 Desktop


I am trying to install OpenSUSE 11.3 on a Dell T3500 Desktop machine. The configuration (related to the problem) of the machine is as follows:

Intel Xeon CPU W3520, 4GB RAM
Intel 82801 SATA RAID Controller
Samsung HD161GJ 160 GB SATA,
Optiarc DVD±RW AD-7230S

When I try to boot from the OpenSUSE 11.3 x86_64 DVD, I get a curses based screen which says, “Make sure that CD number 1 is in your drive.” (with OK and Back buttons). On pressing ‘Back’ and trying to install again, I get an angry red dialog, which declares, “No repository found.”

I tried connecting an external USB DVD drive and then booting from it, then this problem did not come and the install went to start the GUI. But then it could not find the (rather any) hard disk!

We have a set of these identical machines and the problem is fully repeatable on all of them (I tried downloading and burning the DVD image again, that didn’t help). The same machines have OpenSUSE 11.1 and 11.2 installed on them and there was no such problem installing those.

Any suggestions would be greatly appreciated :slight_smile:


Do you get this first and have you done as illustrated:

Well, I checked the MD5 of the ISO image and it matched with the one on the download site. But I didn’t do the media check; will do that once I get to office tomorrow (I work in Bangalore).

I used the same media to install on an older Dell desktop (Dell OptiPlex GX620, Intel 82801G IDE Controller, Seagate 80GB ST3808110AS HDD and HL-DT-ST DVD±RW GWA4164B DVD Drive) and it went through without any problems. This problem is repeatable 100% on all Dell T3500 machines we have (on top of it, “Make sure that CD number 1 is in your drive” comes only when booting from the internal DVD drive).


I fairly sure I have seen some threads on Dell machines here, where Raid had to be taken out of the mix.

Yes, caf4926 it was the RAID controller which was causing the problem. Thanks for the hint. This is how it got working:

  1. Enter the Dell T3500 setup and navigate to Settings > Drives >SATA Operation
  2. There would be three options: RAID Autodetect / AHCI; RAID Autodetect / ATA; RAID on. By default the “RAID on” option would be selected.
  3. Select “RAID Autodetect / ATA” instead and then go ahead with the installation.

After changing the “SATA Operation” option, the OpenSUSE DVD was detected and the install went through. However, OpenSUSE 11.1 and 11.2 didn’t get confused with the default “RAID on” option and could be installed without any trouble. I wonder what has changed in 11.3 to cause this weird behavior.


I never use RAID and know nothing much of the subject, except to say it generally causes problems.

Dear Indrajit,

I’m facing the same problem with my Toshiba Satellite Pro. I see you installed openSuSE 11.3 on your Dell T3500. Since I’m not familiar with the 3-step process you performed to guide your machine detect the openSuSE DVD, I’d appreciate your input for my Toshiba. Here’s my original message in this forum:

I have a Toshiba Satellite Pro laptop with the following specifications:

Proccesor: Intel Core i3 350M / 2.26 GHz
Hard Disk: 320GB SATA 5400rpm
Architecture: x86_64

The computer has already Windows 7 installed on the C drive whereas there’s a D hidden drive with a copy of the recovery image.

I’m having trouble to install openSuSE 11.3 as follows:

I boot the system with the DVD in its drive. After the welcome screen the process stops
using the typical GUI interface and runs a less graphical one. It is at this point where a
window pops up with a request:

“Make sure that CD number 1 is in your drive”

I press OK but the window keeps popping up. Frustrated I hit Back and a red window comes up with the message:

“No repository found.”

I cannot go any further than this point. It’s obvious that the system does not seem to be able to detect the DVD.

Ok, I know this is an old thread, but I too am struggling to get OpenSUSE to install on my Dell T3500s, but I have some info:

The linux kernel in 11.3 sucks and won’t see SATA dvd/cd drives… so that is why the Dells and starting soon almost all modern computers are having problems installing from the dvd.

I also have a question: the Dells came factory with RAID on, and so Windows was installed on the other drive with RAID on. Am I going to have to keep switching back and forth between RAID autodetect/AHCI and RAID to prevent destroying one of my installs? I am installing on two separate drives, but it is such a hassle to boot bios every time I want to boot the other system.

Quite simply a load of old codswallop