Error in yast...

Hi everybody!

I’ve just installed opensuse trough netinstall in one of my computers. I’ve been using opensuse for almost four months now, but only today I’ve decided to install it on my main computer. Everything went pretty well, I have everything configured and running properly. But suddenly, when I needed to do something through yast, I got this error message:

“ => not found
warning: the gtk frontend is installed but does not work
GTK GUI wanted but not found, falling back to Qt.
Error while creating client module sw_single”

I can’t access anything in yast now! Can you help me solving this problem?

Seems like this is somewhat common. Not sure why only some people get this.

This thread may help
dbus error - openSUSE Forums

Ok, I’ve done this, but I still get the same error message. I just can’t update as it says to, yast doesn’t work…

I think maybe you are not telling us something.
You just installed this by the sound of it? And you have been using openSUSE for 4 months on other computers.

Was this a net install? Did it complete without errors.
If you used DVD/CD did you do the media check.
Have you installed anything or deleted anything since install.

Did you do it as root?

Yes, I’ve installed it yesterday on my main computer, which I’m currently using, the other ones I use spontaneously and I’ve never updated anything on them, they’re basically for tests. It was a netinstall and it completed with no errors. Finally, I’ve uninstalled some programs that I don’t use, like gnome-do and gimp.

Yes I did.

Try downloading and manually re-installing zypper the rpm way.

From here: Zypper/Packages - openSUSE??

I see no version for 11.2, that’s why I’m asking…

Form here:
Index of /distribution/11.2/repo/oss/suse

Just navigate to the correct directory depending if you are _64 or not

Guess what, another error message: “failed to get supported types for the backend: Launch helper exited with unknown return code 1”
I think I’ll try 11.3…

Anyway, thanks a lot for your time.

The method for install is

rpm -ihv <packagename>

but you may need the --force at the end

rpm -ihv <packagename> --force

I am dealig with the same situation. Just forced install of satsolver and libzyppp. Yast seems to work now. I downloaded the rpms from the distro i586 directory and used the rpm -ihv <packagename> --force command from the directory that I saved the packages to. (don’t forget to prefix the package name with ./ ) Just randomly clicked many yast options and they are working. I will try and let “you” know if anything fails from here.
Also i have used this disk on this hardware before and have never had this problem.

11.2 DVD install
KDE option
IDE drives
MSI main board MS-7236 ver 2.2
3.0 ghz hyper threader (yea old stuff)


It’s working! I can now use all yast’s functionalities! Thank you caf4926 for your patience and time, and thank you jgaupel for the final push I needed.

Well done! :wink:




i am stuck in the wrong forum with the same title

failed to get supported types for the backend: Launch helper exited with unknown return code 1

this is happening to me too.
I hope somebody has the fix
Any suggestions please

failed to get supported types for the backend: Launch helper exited with unknown return code 1

Does anyone have the fix for this issue??
I have just updated my system to 64 and cant install