[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

Hi.

yesterday I upgraded my openSUSE tumbleweed installation from 20170414 to 20170424. after upgrade bumblebee does not working for me anymore.

everything was fine on tumbleweed 20170414, Kernel 4.10.9.
Now when I run “optirun glxgears” I get this error:



[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ERROR]Aborting because fallback start is disabled.

also tried this:
https://en.opensuse.org/SDB:NVIDIA_Bumblebee#Problems_with_GT600M.2FGT700M_series_cards_.28Kepler.29

didn’t worked, and my GPU is not from Kepler series.
using nvidia-bumblebeed package ( 375.39) driver from X11:bumblebee repo


output of systemctl status bumblebeed:


* bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2017-04-27 14:05:29 +0430; 16s ago
 Main PID: 2791 (bumblebeed)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bumblebeed.service
           `-2791 /usr/sbin/bumblebeed

Apr 27 14:05:29 simorgh systemd[1]: Started Bumblebee C Daemon.
Apr 27 14:05:29 simorgh bumblebeed[2791]:   875.184555] [INFO]/usr/sbin/bumblebeed 3.2.1 started
Apr 27 14:05:35 simorgh bumblebeed[2791]: modprobe: ERROR: could not insert 'nvidia': No such device
Apr 27 14:05:35 simorgh bumblebeed[2791]:   881.370199] [ERROR]Module nvidia could not be loaded (timeout?)
Apr 27 14:05:35 simorgh bumblebeed[2791]:   881.370233] [ERROR]Could not load GPU driver


output of dkms status:


nvidia, 375.39, 4.10.10-1-default, x86_64: installed

systemctl status dkms:


● dkms.service - Dynamic Kernel Modules System
   Loaded: loaded (/usr/lib/systemd/system/dkms.service; enabled; vendor preset: disabled)
   Active: active (exited) since Thu 2017-04-27 13:51:25 +0430; 36min ago
  Process: 1202 ExecStart=/usr/lib/systemd/system/dkms.systemd start (code=exited, status=0/SUCCESS)
 Main PID: 1202 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/dkms.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

lspci -nnk | grep -i vga -A3 :


00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
        Subsystem: Lenovo Device [17aa:3904]
        Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 635M] [10de:0de3] (rev a1)
        Subsystem: Lenovo Device [17aa:3904]
        Kernel modules: nouveau, nvidia_drm, nvidia

uname -r


4.10.10-1-default


1 - also tried different repos and different versions (378.13), same problem.
2 - cat /proc/acpi/bbswitch (before I run optirun glxgears)


0000:01:00.0 OFF

after I run optirun glxgears:


0000:01:00.0 ON

and it never goes off until I turn off it from terminal.
3- if I remove nvidia dkms module, dkms autoinstall ( and dkms install ) won’t install it again.


no Idea how to fix this

after many tries, decided to switch back to Leap. Installed leap 42.2 and updated the system packages. and installed nvidia drivers from nvidia repos and bumblebee from this guide, and same thing happened. not sure why bumblebee is not working for me anymore, seems I have to switch back to suse-prime package. sounds weird…

found some interesting information.

dmesg:


  118.508983] bbswitch: enabling discrete graphics
  118.766600] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
  118.766638] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de3)
               NVRM: installed in this system is not supported by the 375.39
               NVRM: NVIDIA Linux driver release.  Please see 'Appendix
               NVRM: A - Supported NVIDIA GPU Products' in this release's
               NVRM: README, available on the Linux driver download page
               NVRM: at www.nvidia.com.
  118.766751] nvidia: probe of 0000:01:00.0 failed with error -1
  118.766786] nvidia-nvlink: Nvlink Core is being initialized, major device number 248
  118.766810] NVRM: The NVIDIA probe routine failed for 1 device(s).
  118.766812] NVRM: None of the NVIDIA graphics adapters were initialized!
  118.766813] nvidia-nvlink: Unregistered the Nvlink Core, major device number 248



maybe it’s a driver bug. I’ll stick with suse-prime package for now

I got Bumblebee to work using https://en.opensuse.org/SDB:NVIDIA_Bumblebee with a few minor changes to the procedure, which I posted here: https://forums.opensuse.org/showthread.php/522726-New-instruction-for-Bumblebee.
Running a fresh Tumbleweed install with a NVIDIA Geforce 710M card.

I haven’t tested it with Steam yet, but I’m not getting an error when starting stuff with optirun.

It’s working again on kernel 4.4.62-18.6-default after latest update. So, problem solved :slight_smile:
maybe it’s also fixed in tumbleweed kernel.

to make sure it’s kernel related, I checked the old kernel, still does not working.