Epivalley Sec 8380 mobile connection

I had posted this message earlier. Unfortunately it was not put up on the forum.
I have recently updated form Suse 11.1 to Suse 11.2. When I connect the above USB modem it is recognised by the system and I configured through yest>network>modem.But it did not work. Then I used wvdialconf and could get connected only once through wvdial. But subsequent connection fails. Each time I connect it to the system it gets attached to a different ttyACMn where n value varies from 0 to 7. So if want to dial I have to use each time the commands
#>wvdialconf /etc/wvdial.conf
#>wvdial
It initialises the modem but the connection fails with the following message

linux-ab5h:~ # wvdial
→ WvDial: Internet dialer version 1.60
→ Cannot get information for serial port.
→ Initializing modem.
→ Sending: ATZ
ATZ
OK
→ Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
→ Sending: AT+CRM=1
AT+CRM=1
OK
→ Modem initialized.
→ Idle Seconds = 100, disabling automatic reconnect.
→ Sending: ATDT#777
→ Waiting for carrier.
ATDT#777
CONNECT 3600000
→ Carrier detected. Starting PPP immediately.
→ Starting pppd at Sun Jul 4 16:40:36 2010
→ Pid of pppd: 688
→ Using interface ppp0
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ local IP address 115.118.236.55
→ pppd: п��8�[06][08](�[06][08]
→ remote IP address 172.29.243.145
→ pppd: п��8�[06][08](�[06][08]
→ primary DNS address 121.242.190.180
→ pppd: п��8�[06][08](�[06][08]
→ secondary DNS address 121.242.190.211
→ pppd: п��8�[06][08](�[06][08]
→ Script /etc/ppp/ip-up run successful
→ Default route Ok.
→ warning, can’t find address for www.suse.de
→ warning, address lookup does not work
→ Nameserver (DNS) failure, the connection may not work.
→ Connected… Press Ctrl-C to disconnect
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ Connect time 0.2 minutes.
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ pppd: п��8�[06][08](�[06][08]
→ Disconnecting at Sun Jul 4 16:40:48 2010
→ The PPP daemon has died: A modem hung up the phone (exit code = 16)
→ man pppd explains pppd error codes in more detail.
→ Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

I have tried all possible suggestions given on this forum including installing latest version of usb_modswitch.
I have switched to Linux a year back. Please provide some expert help?
Thanks in advance.

Toshiba Satellite Pro,Intel Centrino 2.2 Ghz, 2 GB Ram,Suse 11.2 with KDE desktop

I note a thread here discussing this …
CAN LINUX EXIST WITHOUT MICROSOFT WINDOWS?
… depending on how both threads move forward, I may use my moderator permissions to merge the two threads. But for now I’m just watching (I don’t know the technical solution).

kkphani wrote:
> → Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
> ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
> CONNECT 3600000
> → local IP address 115.118.236.55
> → remote IP address 172.29.243.145 → pppd:
> → primary DNS address
> 121.242.190.180 →
> secondary DNS address 121.242.190.211 →
> Default route Ok. → warning, can’t find address
> for www.suse.de → warning, address lookup does not work →
> Nameserver (DNS) failure, the connection may not work. →
> Connected… Press Ctrl-C to disconnect → pppd:
> Connect time 0.2 minutes. →
> The PPP daemon has died: A modem hung up the
> phone (exit code = 16) → man pppd explains pppd error codes in
> more detail. → Try again and look into /var/log/messages and the
> wvdial and pppd man pages for more information.

dang, dial up is so far back in my history i’m not sure i can remember…

first: do you have the Windows disk that came with that device? if so,
put the disk in the disk caddy and then use some kind of viewer (like
KWrite to open the file on the disk and search for the string ATZ,
shortly after you should find a string beginning with ATx…x where
AT is followed by many different letters/numbers, that AT beginning
string will be your modem manufacturers SUGGESTED modem initialization
string…

[random info on modem commands:
http://uic.edu/depts/accc/network/dialin/modem_codes.html]

i guess the string you are using [ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0] was a
‘generic’ initalization string provided by the wvdial developer…it
may, or may NOT include the correct string to tell the modem how to
terminate the connection and leave the modem in the correct
configuration for the next dial up…

as i faintly recall almost all modem initalization strings begin with
AT&F, where as the one you are using begins ATQ0…so, i don’t know
where your sting came from…

so, that initialization string you find on the modem makers disk
might solve that restart problem…

but WAIT: the makers disk may have the correct initalization string
for EVERY modem that maker has ever made, from 1960 to present…so,
when you find that ATZ then look around and see if there is a model
number…or, search first on the model number and see if it exists in
the file (RIGHT! i didn’t tell you which file to look in, because i
don’t know what the manufacturer wanted to call it…

OH! do you dual boot and does the modem work with windows? if so, look
in the windows registry…search for AT[something that resembles the
above which linux is using, and then]

once you have found the recommended initialization string shove that
into wvdial however its doc tells you to do that (maybe via dialconf,
or pppconf or or or…)

also, i see it is not resolving www.suse.de, which means you must have
a DNS problem…do you know the DNS your ISP tells you to use? did you
put that into wvdial’s setup? you are using 121.242.190.180 and
121.242.190.211, is that what you are supposed to use with your ISP?

the output from the modem says the line was dropped because the modem
hung up and to “look into /var/log/messages and the wvdial and pppd
man pages for more information.”

did you do that, were there hints in the logs as to why the modem hung
up almost immediately (0.2 minutes), uncommanded? was it only because
the IP for the Domain Name Server (DNS) was incorrect (if it is) or
was there hints about the modem itself not liking the initialization
string?

oh, and if you can’t (with the right modem string and DNS setting) get
wvdial to work i think there is still a kppp (which is what i used
last, i think)


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Thanks.
The modem string is ATQ0.
I did not put the DNS adress it auto detects.
Strange part is that I boot on WINXP activate modem ->connect->disconnect without switching off the modem and then restart the computer and boot in Suse, it gets connected with one click on kinternet icon. Same is the case with Fedora 10 which is also on my computer. In Fedora even though it is connected Selinux message comes up saying that mobile is not connected because of some trouble between Selinux and pppd.

kkphani wrote:
> Thanks.
> The modem string is ATQ0.

that is a very strange modem initialization string…so, where does
all the other stuff [V1 E1 S0=0 &C1 &D2 +FCLASS=0 ATQ0 V1 E1 S0=0 &C1
&D2 +FCLASS=0] come from?

and is it correct for the setup you need to use?

did you get a disk with the USB device, or not?

if so, you must set up the device to work with linux or it will
not…and, i guess the disk you got with the device does NOT have a
linux driver included, right?

> I did not put the DNS adress it auto detects.

very strange…you are saying the ISP you are hooking to is providing
DNS but it does not work to translate suse.de into an IP…

not likely…didn’t you set up your network somewhere? how else did it
learn the number to call?

please do the following in a terminal and copy/paste the results back
to here:


cat /etc/resolv.conf

> Strange part is that I boot on WINXP activate modem
> ->connect->disconnect without switching off the modem and then restart
> the computer and boot in Suse, it gets connected with one click on
> kinternet icon.

are you saying if you shut down your computer at night, and then in
the morning boot directly to openSUSE you can not use your modem?

at all?

i mean, it will not dial? or anything else?

or it will dial but will not connect?
or, dial and connect and then immediately shutdown?

i guess i’d try unplugging the USB modem from the computer before
turning on power…then, after the machine is fully up and running,
i’d up plug it in the modem and give it a minute or so to be found by
the system and (hopefully) made ready to work…

THEN, see if you can click the “kinternet icon”…

> Same is the case with Fedora 10 which is also on my
> computer. In Fedora even though it is connected Selinux message comes up
> saying that mobile is not connected because of some trouble between
> Selinux and pppd.

last time i used Fedora (2, i think) it ran fine with kppp or
something… :slight_smile:


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Thanks again for the prompt reply.
You are correct. I do not have a disk with linux driver. The supplier does not support linux officially. However, they provided the modem initialising string claming it has worked with linux. Here is cat /etc/resolv.conf output

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 192.168.1.1
nameserver 121.242.190.180
nameserver 121.242.190.211

yes if i switch off the computer and directly boot in Suse the modem does fuction. It gives the message which I have posted earlier. If I disconnect the modem and reconnet and wait for some time and then try to dial - the message comes “can not find /dev/ttyACM0” because the modem gets mounted at /dev/ttyACM1.
If i modify wvdial config to include /dev/ttyACM1 and dial the previous message comes back. kinternet does not provide any response during this operation. Only way so far is to go through WinXp and I have no problem in connection. As suggested by you I have tried this several times by plugging and unplugging it would not work. As it is now WinXp is the only solution to connect. This what I dislike.

One more thing I would like to add - when i use the command wvdialconf to generate
wvdial.conf I get this

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem =dev/ttyACM0
;Phone = <phone no>
Idle Seconds = 100
;Password = <password>
Modem Type = USB Modem
Baud = 460800
Dial Command = ATDT
Ask Password = 0
ISDN = 0
;Username = <userid>
Flow Control = Hardware(CRTSCTS)

kkphani wrote:
> when i use the command wvdialconf
> to generate
> wvdial.conf I get this
>
> [Dialer Defaults]
> Init1 = ATZ
> Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
> Modem =dev/ttyACM0
> ;Phone = <phone no>
> Idle Seconds = 100
> ;Password = <password>
> Modem Type = USB Modem
> Baud = 460800
> Dial Command = ATDT
> Ask Password = 0
> ISDN = 0
> ;Username = <userid>
> Flow Control = Hardware(CRTSCTS)

ok, listen–i have done this (with Win3.1) and you can do it now with
XP…or you can find a windows guru who can tell you where to find the
info in the registry and in the windows dialer log–you must learn
what XP is using for:

-the full initialization string 1 (ATZ, may or may not be right)

-the full init string 2 (probably not be ATQ0 V1 E1 S0=0 &C1 &D2
+FCLASS=0)

-the phone number (your first post shows #777, is that correct?)

-primary DNS IP (post 1=121.242.190.180 post 6=192.168.1.1)

-2nd DNS IP (post 1=121.242.190.211 post 6=121.242.190.180)

once you have learned what works with XP you can use that information
to configure the Linux dialer to feed the same info to the same modem
and it will work the same way (it can not tell if XP, Linux, Mac or
Timbuktu is sending the commands)

if you cannot find the info in XP, as mentioned earlier, all of that
information also exists on the disk which came with the modem…all
you have to do is find it in the config files…

you CAN do this…


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Thanks for all your help. Wasted another 2 hrs could not get a solution through Windows files. Anyway I have to live with it.

kkphani wrote:
> Thanks for all your help. Wasted another 2 hrs could not get a solution
> through Windows files. Anyway I have to live with it.
>
>
sorry i couldn’t make it smoother…
final try: i suppose the modem you are using is widely used in your
area…so, contact your nearest Linux User Group and see if someone
there has figured out how to do the right way (not needed the Dark
Side to set up the modem), see here: http://www.linux.org/groups/

hmmmm…that site seem to currently be off the air


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Hi kkphani

This thread has only just come to my attention.

If I disconnect the modem and reconnet and wait for some time and then try to dial - the message comes “can not find /dev/ttyACM0” because the modem gets mounted at /dev/ttyACM1.

I had a huawei usb device that behaved like this (incrementing /dev/ttyUSB* device nodes) if I kept removing and inserting it IIRC. It is possible to write a custom udev rule to symlink your device to /dev/modem upon insertion, such that regardless of /dev/ttyACM* device number, you can connect via /dev/modem.

You need to uniquely identify your device via info form this command

lsusb

Then open a text file ‘/etc/udev/rules.d/95-epivalley.rules’ (or similar) as root

kdesu kedit /etc/udev/rules.d/95-epivalley.rules

and add a line like

SUBSYSTEM=="usb", SYSFS{idVendor}=="****", SYSFS{idProduct}=="****", SYMLINK="modem"
 

Replace the ‘****’ characters with the vendor and product ID’s from the lsusb results for your device.

The next time you insert your modem device, /dev/modem should be created automatically. This can then be configured via yast.

Did as instructed above. I had luck only for the first time. Second time it did not work. It did not create /dev/modem. I tried with usb_modswitch since it is a multimode modem - following are the output of commands:

l# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 1b7d:0001
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 093a:2510 Pixart Imaging, Inc. Hama Optical Mouse
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

usb_modeswitch -W -v 0x1b7d -p 0x0001

Taking all parameters from the command line

  • usb-modeswitch: handle USB devices with multiple modes
  • Version 1.1.3 (C) Josua Dietze 2010
  • Based on libusb0 (0.1.12 and above)

! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor= 0x1b7d
DefaultProduct= 0x0001
TargetVendor= not set
TargetProduct= not set
TargetClass= not set
TargetProductList=""

DetachStorageOnly=0
HuaweiMode=0
SierraMode=0
SonyMode=0
GCTMode=0
MessageEndpoint= not set
MessageContent=""
NeedResponse=0
ResponseEndpoint= not set
Interface=0x00

InquireDevice enabled (default)
Success check disabled
System integration mode disabled

Looking for default devices …
searching devices, found USB ID 1d6b:0002
searching devices, found USB ID 1d6b:0002
searching devices, found USB ID 1d6b:0001
searching devices, found USB ID 1d6b:0001
searching devices, found USB ID 0483:2016
searching devices, found USB ID 1d6b:0001
searching devices, found USB ID 1b7d:0001
found matching vendor ID
found matching product ID
adding device
searching devices, found USB ID 1d6b:0001
searching devices, found USB ID 093a:2510
searching devices, found USB ID 1d6b:0001
Found devices in default mode or class (1)
Accessing device 002 on bus 005 …
Not a storage device, skipping SCSI inquiry

USB description data (for identification)

Manufacturer: EpiValley Incorporated
Product: EpiValley CDMA USB Modem
Serial No.: not provided

Warning: no switching method given.
-> Run lsusb to note any changes. Bye.

usb_modeswitch -W

  • usb-modeswitch: handle USB devices with multiple modes
  • Version 1.1.3 (C) Josua Dietze 2010
  • Based on libusb0 (0.1.12 and above)

! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor= not set
DefaultProduct= not set
TargetVendor= not set
TargetProduct= not set
TargetClass= not set
TargetProductList=""

DetachStorageOnly=0
HuaweiMode=0
SierraMode=0
SonyMode=0
GCTMode=0
MessageEndpoint= not set
MessageContent=""
NeedResponse=0
ResponseEndpoint= not set
Interface=0x00

InquireDevice enabled (default)
Success check disabled
System integration mode disabled

No default vendor/product ID given. Aborting.

I think I am not able to cofigure it with usb_modeswitch. Can I get some help.
Thanks.

Just a small thought (I have not any mobile broadband modem):

Maybe upgrading to NetworkManager 0.8 is able to help?
NetworkManager/ReleaseProcess - GNOME Live! :

0.8

The 0.8 release was tagged on 2010-02-18.

New Features

Improved mobile broadband support using ModemManager for wider hardware support …]
Good luck
pistazienfresser

I think I am not able to cofigure it with usb_modeswitch. Can I get some help.
Thanks.

I’m not sure that you need usb_modeswitch - its for devices that show up as cdrom storage devices, and need to be switched to show the modem device.

Try removing the ‘cdc_acm’ module before reinserting your modem device with

rmmod cdc_acm

You’ll need to be root first with ‘su -’ command.

If that works, then we may be able to add that to the udev entry. (I’ve read somewhere that some devices behave like this with the usbseial and cdc_acm drivers).

Thanks for prompt response.
Did as you said but without any result. I think I need usb_modeswitch because when it plugged in linux it shows as a dual device.

deano ferrari wrote:

> This thread has only just come to my attention.

shape up! :wink:

(wish you had come sooner!!)


Enjoy Packman’s benefits? Show your appreciation by donating at
http://se.unixheads.org/?donate

DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

shape up! :wink:

(wish you had come sooner!!)

Thats the trouble with moonlighting! You get tired! :slight_smile:

I think I need usb_modeswitch because when it plugged in linux it shows as a dual device.

Its only used for those devices that look like storage devices until mode switched. From what you’ve posted so far, you have a ttyACM* device present as soon as you plug your modem in (via cdc_acm driver). As I understand things, it just keeps increnemting each time you plug it in, unless you reboot. Is that correct?

The device behaviour can be clarified by rebooting, then once the system is up, plug in the modem and type

dmesg |tail

Any references to storage devices mean the usb_modeswitch may be applicable. If /dev/ttyACM0 appears in the output, then your device is ready to go without it.

The problem is each time you plug it in, a new incremented /dev/ttyACM* is created (as far as I uderstand), which means your modem configuration then ceases to work. I was trying to assist with a udev line to create /dev/modem each time. Not sure why that didn’t work each time though.

I think I may have made a typo with the ‘symlink’ assignment key. The rule should look like

SUBSYSTEM=="usb", SYSFS{idVendor}=="1b7d", SYSFS{idProduct}=="0001", SYMLINK+="modem"

This similar rule may work better for you

KERNEL=="ttyACM*", SYSFS{idVendor}=="1b7d", SYSFS{idProduct}=="0001", SYMLINK+="modem"

Others please feel free to correct or assist here…

BTW, for those that are interested:

OpenSUSE 11.1 Reference - Influencing Kernel Device Event Handling with udev Rules

deano ferrari wrote:
> BTW, for those that are interested:
>
> ‘OpenSUSE 11.1 Reference - Influencing Kernel Device Event Handling
> with udev Rules’ (http://tinyurl.com/23qmeg9)
>
>
oh wow…i had totally missed Linuxtopia! what a gold mine, thanks!!!


Enjoy Packman’s benefits? Show your appreciation by donating at
http://se.unixheads.org/?donate

DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]