Emerald on 11.1

I installed successfully compiz-gnome and all its dependencies, it works well except emerald, the window decorator. When i type

emerald --replace

the decorations disappear and nothing is written in the terminal, i have to go back to gtk.
I’m running x86_64, all the compiz rpms come from the XGL repo.
Any ideas?

I’m wondering the same thing for KDE 4 and Compiz/Emerald…

I had the same problem with emerald from suse repos. I tried emerald from compiz repos Additional YaST Package Repositories - openSUSE and those do work. However compiz is very buggy in my version. It often falls back to metacity…


the same here with KDE 3.5. and Nividia 8800GTS. Compiz doesn’t work at all.
I also tried this one: openSUSE 11.1 Compiz & NOMAD (xrdp) | Ben Kevan’s Blog, but it does nothing.

Hi !

The same here with KDE4 and 11.1

emerald --replace doesn’t work

I have made some researches on the internet and I found that I had to go to kcontrol->advanced tab->session manager and choose between kwin and emerald but there isn’t such a choice in that tab.


I followed the link openSUSE 11.1 Compiz & NOMAD (xrdp) | Ben Kevan’s Blog as you said and now compiz runs much better. No bugs until now. However I can’t get emerald to work with this version of compiz. I also tried to install emerald from the compiz repo to use with compiz from the XGL repo but no success…

Update got emerald back by using emerald packages from standard opensuse repositories. Now got a working compiz and emerald:). Turned of the compiz repos and never going to update compiz because now it works and I want to keep it that way.

Just to confirm, I had the issue of emerald not loading. However, after reverting emerald to the version in the original opensuse 11.1 repository, it worked. I had installed the version from the X11:XGL repository, where I got a working version of compiz.

Thanks for the help, suskewiet!

I ended up removing all traces of Compiz and Emerald, clearing out my Compiz settings, and reinstalling successfully via 1-click install; however, while Compiz works now, Emerald still does not.

On 11.0 I was able to enable Compiz+Emerald by going into Desktop Management\Default apps\Window Manager and selecting Compiz.

Now I can’t see window decorations. I can’t start Emerald nor rotate the cube or whatever.

I have an ASUS G71V with nVidia 9700M GT with proper drivers installed. glxgears works fine.