Emacs editor window ugly font


I’m using KDE 4.9 with openSUSE 12.2. In one of my machines, Emacs’s editor window’s font is ugly. Specifically, they are very “fat”.
Stangely the font on the menu of the emacs window are correctly rendered.

I have included a screenshot: https://dl.dropbox.com/u/561594/snapshot1.jpeg
As you can see, even though the letters on the menu are crisp, while the font on the editor window is blurry.


You can enter a…

Alt-F2: kdesu qtconfig

Run QT Config and change the font or what ever from there. In KDE you can also go to …

menu / Configure Desktop / Application Appearance / GTK Styles and Fonts and make some adjustment there as well.

Thank You,

On 01/15/2013 02:46 AM, joonro wrote:
> Emacs’s
> editor window’s font is ugly.

so change it to a font you like!
click on Options and uncheck “Use system font” then click on “Set
default font” and pick whatever is not ‘ugly’ to you.

dd http://tinyurl.com/DD-Caveat

Thanks for the reply. I tried all those before I asked the question, but it did not help. I have three machines with openSUSE, and two laptops with intel graphics have this problem while a desktop with nvidia doesn’t, so I wonder if it has something to do with graphics.


Besides just personnel tastes, the graphics chipset and even the monitor plays a role in the appearance of any of the application screens. I have had no problem changing the default font and finding one I like better. Except for my work laptop which uses Intel, I use nVIDIA based video and I feel it really works best for me.

Thank You,

Please read my post before replying - or maybe I did not explain it well enough. I am using the SAME font for both the menu and the editor window. And they are being rendered DIFFERENTLY.


Thanks for the reply. Maybe I did not explain it well enough in my original post. The problem is that even if I use the same Dejavu sans font (whith is the font used for the emacs menus) for the Default font, the letters in the editor window are being rendered differently - they are fat, when the letters on the menu look normal.

I just tried dejavu sans extralight - which is supposed to be very thin - but still in emacs window the letters look fat. Very strange.


Setting the subpixel rendering option to RGB and Hinting style to Full in the KDE system settings fixed the problem.
It was strange - without the option set, majority of fonts were rendered as if subpixel hinting was set, some were not.

Thanks for you help!


On 01/17/2013 06:06 AM, joonro wrote:
> Please read my post before replying - or maybe I did not explain it
> well enough. I am using the SAME font for both the menu and the editor
> window. And they are being rendered DIFFERENTLY.

sorry, i didn’t understand that the fonts used were the same, just that
one looked good and one looked fat…anyway, i’ve looked at the jpg in
the URL you posted and on my machine, graphics set and monitor i can’t
see that there is any difference in fatness between the good and the
ugly fonts!

now that you have changed the subpixel rendering in the troublesome
machine, take another look at

i’d love to know if you can still see the fat problem, or not (i still


I also have setup this in KDE as well. Happy you found it as I did not think to mention it. It is my understanding that not all fonts respond to this setting properly, but I am not sure which ones have a problem. But in any event, I am happy you found the fix you required.

Thank You,

Apologies, I should have described the problem better. I agree it is hard to recognize it - but I have another snapshot with correctly rendered font - you should able to see the difference if you look at the two images. https://dl.dropbox.com/u/561594/snapshot2.png


Thank you. Again the weird thing was that the same dejavu fonts were bering rendered differently depending on places - I guess for some places the subpixel hinting settings were applied automatically.