Edimax EW-7711UTN WiFi 'N' Mini USB Adapter

I’m having issues…

Plugged in, Green led light came on, but not detected as a Network Adapter…

So i put in my OpenSuSe 11.1 DVD, looked at the System Devices during installation, wasn’t there…

Installed Linux, opened up Network Configuration, wasn’t listed…

Opened up Hardware Information, found it. but it was recognised as a device…

So i googled ‘7711UTn Linux’ and found this

Rainbow Cybernuke - Connecting my opensuse 11 with LAN adapter Edimax Ew-7711UTn

This adapter uses the classic Ralink RT2870 driver which is included in the 2.6.27 kernel of the current Opensuse distribution. I plugged the mini adapter into a usb hub, and it was immediately identified.

lsmod | grep 2870

rt2870sta 460004 1
usbcore 165892 6 rt2870sta,usb_storage,usbhid,uhci_hcd,ehci_hcd

I checked OpenSuse 11.1 detected the WiFi Card…

administrator@linux-j3pg:~> lsmod | grep 2870
rt2870sta             460004  1 
usbcore               165892  5 rt2870sta,usbhid,ehci_hcd,ohci_hcd


he then goes onto say

At this point you can use YAST to configure the wireless network, or do it manually using wpa_passphrase. In this latest case you would do something like

and then later

But in my case I simply used YAST/Network Device/Network Stettings/Wireless. It generates the /var/run/wpa_supplicant-ra0.conf file with the ssid and psk information. It would then be just the passphrase used as key, and not the one generated with wpa_passphrase.

I’d rather configure using YAST but by the seems of it I can’t…


Is it time i tried the other instructions he mentions?.. or could any of you help? :smiley:

ok, I tried the instructions he had.
but they didn’t work, because apparently those directories don’t exist. :frowning:

Installing 11.2 Milestone-3 now, with hope it recognizes it :smiley:

Ok, didn’t work :(…

Tried an Edimax EW-7728ln Wireless PCI Card. It Recognized it, scanned networks, found my network, but couldn’t connect. Signal Strength was 91% so i don’t think distance was an issue.

Well now I’ve moved my Edimax EW-7728ln back to my PC, plugged in the original EW-711Utn Adapter. And I’m downloading Windows Server 2008 R2 and give that a shot.

Doubt It will work though :frowning:

don’t you just hate it when that happens?

Yup, Didn’t work, so i dragged the PC back downstairs and hooked it up with ethernet…
although i do hope there is a solution to this RT2870sta driver when my extension has finished :smiley: