EasyTag still taking over!

I am getting a similar problem to this post (How use Dolphin to “open containing folder” from firefox downloads?) only I’m using Gnome3. I’m trying the same techniques but just wanted to ask if anyone else is still experiencing this issue. I have found posts on this dating back to 2008 across several window managers and distributions! This has got to be a problem with EasyTag and not the distros.

i’m having the same problem… Any solution yet?

The only solution I have found was to uninstall EasyTag unfortunately.

I tested EasyTAG few times and I am still not convienced that this is the tool I like
(Long time ago I even posted something about it - Edycja tagów ID3 w plikach MP3 | Two things are infinite… )
I use mp3tag (at the moment 2.49a) with WINE and its working perfectly (not everything works so good with WINE).
You might consider to uninstall EasyTag and use mp3tag (Mp3tag - the universal Tag Editor (ID3v2, MP4, OGG, FLAC, …))


mp3tag is a great program. I used it all the time in windows and I agree it works perfect under WINE. I’ve used it in Linux quite a bit too.

Yes, mp3tag is indeed one of the best i’ve experienced. Although i hate wine, with playonlinux, installation and runing mp3tag is easy :slight_smile:

Yeah, easyTag is a PITA. I used it once to edit the tags of a bunch of mp3’s once. That took a long time. Then, to add insult to injury, Amarok/Clementine couldn’t even tell the tags had changed & I had to go and change them in there again before it stuck.

EasyTag > /dev/null

Also, it took over the opening folders job as well. Dumb.

This Bug Report that I have just emailed to easytag-mailing@lists.sourceforge.net may be related.

Subject: EasyTAG- Bug Report - Inappropriately specified mimetype in desktop file causes problems


Operating System = openSUSE 12.1
kernel = Linux 3.1.9-1.4-desktop
Desktop = Gnome 3.2.1

Before installing EasyTag, whenever (usb) removable media devices were inserted, the resulting dialogue box looked similar to this example
(where  ],   ] and /\ represent icon approximations):

 |  ] FAT32                                                             |
 |             ] Open with Files                                        |
 |            /\  Eject                                                  |

After installing EasyTag however, the top option Open with Files was inappropriately replaced with Open with EasyTag.

Online research suggested that EasyTag defined a non-compliant Mime Type (namely x-directory/normal) in /usr/share/applications/easytag.desktop
and that the use of the x-directory/normal Mime Type was discouraged.

Because of this, I investigated deleting the x-directory/normal Mime Type from the desktop file and the line “x-directory/normal=easytag.desktop”
from /usr/share/applications/defaults.list. These edits indeed restored the (removable media inserted) dialog box to what it was originally.