DVD-RW Drive Fails to Read CD It Just Burned!

Downloaded KDE 3.5 Live CD, md5 and sha1 sums are correct. Then I burned the iso to a clean cd. Upon rebooting with the cd in its drive I selected the ‘Check Installation Media’ from the boot menu. At 81% the check fails:

check: 81%
err: sector 276288
check: md5sum not checked
md5: <an md5 is outputed, but is obviously not right>
-----> Press any key for reboot:

I press a key and then:

-----> CheckMedia
-----> reboot Exception: error consoles at Alt-F3/F4
-----> reboot: reboot in 120 sec…

I press Alt-F3 and don’t really understand what’s on my screen, but Alt-F4 shows:

Buffer I/O error on device sr0, logical block 246289
<Many similar lines like the one above>
sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE, SUGGEST_OK
sr 1:0:0:0: [sr0] Sense Key : Hardware Error [current]
sr 1:0:0:0: [sr0] Add. Sense: Timeout on logical unit
end_request: I/O error, dev sr0, sector 1105408
__ratelimit: 54 callbacks suppressed
<More similar lines like the first one of this quote>

Thinking the burning process had gone wrong I repeated, but ended the same. Then I tried another cd, same result. Next I took the cd to another computer and tried again. Success!

What could be the problem with the dvd-rw drive that I used for burning? It certainly burned it fine. Why is it having touble reading from it afterwards?

What confuses me is that if I select the option to verify written data within K3b no errors are detected. Also, within ‘YaST > Media Check’ I select ‘Start Check’ and a message appears telling me that the md5 checksum cannot be verified, but that the readability of the media can. I select ‘Continue’, the progress bar goes from 0% to 100%, and the result is ‘Unknown’, which is reasonable since whatever md5 sum was calculated cannot be compared. But the contents of the media were read through, right?

What could be the reason for the dvd-rw drive having the read problem while doing a media check from the live cd boot menu?

i remember reading (in the last year) a thread here describing similar
problems…though i do not recall if a solution was found i’d suggest
you try to find that thread using the forum’s search engine, or
perhaps google’s…

i’m pretty sure i remember that there are some DVD/CD drives (and
other hardware) known to not work and play well with operating systems
other than those coming from Redmond Washington USA…

if you can’t find that/those thread(s) here you MIGHT try to see if it
is a known hardware problem via a google search on:

linux [your CD/DVD’s brand | model number]


IIRC the writing and reading lasers are not the same so being able to write is not a guarantee that the same drive can read it. There appears to be nothing wrong with the CD so quite possibly the drive is dying.

Optical drives do strange things. I have one that has no problems burning DVD+RW media but fails to burn DVD-R media. Also has no problems with CD-RW but fails on CD-R. Anyway I only use that drive for burning RW media now so it’s no loss, except of time, if the burn fails. It’s had long service anyway, doing at least a couple of disks a week for 3 or 4 years IIRC.

After reading around a bit I see now that this kind of behavior is not uncommon, though it was a new experience for me.

It’s possible, though I’ve not used mine as much as you have yours. As a matter of fact I’ve hardly used it at all. lol!

Thanks MultiplePersonality and ken_yap!