dvd::rip Questions

I have been trying to get dvd::rip to work, but I have run into some problems. I have been poking around google and looking through the documentation at dvd::rip - A full featured DVD Ripper GUI for Linux, written in Perl. Forgive me if this is inappropriate, but I thought I would post here, since there seems to be a ton of questions about copying dvds on this forum. I guess my problem is that I don’t know what the hell I’m doing :wink:

I have a movie dvd I’m trying to copy (I think what I am doing is legal. If not, it should be.) I was hoping to somehow copy it to my hard drive, and eventually to a dvd. Like, an exact copy of the dvd. I have never really done this before, so I am just sort of feeling my way through.

So I have dvd::rip. My first concern is if I go to ‘debug’ and ‘check dependencies’, I have two that are not met. They are ffmpeg and fping, both listed as non-mandatory. But I don’t understand why they are not met, as both are listed as installed in package manager with better version numbers than recommended. I am a little concerned that maybe the ‘lack’ of ffmpeg is causing problems.

Continuing on, I have read the table of contents of the dvd. I tried to rip title 1, as it is the correct length of the video, so I guess that’s what I want. I can’t rip every title, as they are listed as over 180GB total (why is this?). I get 6 .vod files on my disk, but is stops like 70% of the way through. There is no error message in the log, but the .vod files seem to have all of the movie.

If I go through with the transcode stage using MPEG (is that what I would need to go to a dvd?), it takes over an hour, and at the end there is an error message that pops up in the log:

title #1’ failed with error message:
Command exits with failure code:
Command: execflow -n 19 mplex -f 4 -V -o /home/scott/dvdrip-data/unnamed/avi/001/unnamed-001-%d.mpg /home/scott/dvdrip-data/unnamed/avi/001/unnamed-001.m2v /home/scott/dvdrip-data/unnamed/avi/001/unnamed-001.mpa && echo EXECFLOW_OK

Output: INFO: [mplex] mplex version 1.9.0 (2.2.7 $Date: 2006/02/01 22:23:01 $)
**ERROR: [mplex] Unable to open file /home/scott/dvdrip-data/unnamed/avi/001/unnamed-001.m2v for reading.

Sat Mar 21 22:04:29 2009 Job ‘Multiplex MPEG - title #1’ finished

After this, I get a 2.5 gb file in my avi folder. It has no extension. If I try to play this file, it’s just the sound. It seems to all be there, but is listed as being 45 hours long (just silence once the movie is over).

Argh. This is frustrating! Am I just overlooking something?

I’ve read of some people who swear by dvd::rip, but I confess, I was never able to master it.

Instead, I stuck with a program with a more user friendly gui, such as k9copy.

Here is our how-to/faq page with a summary list of various dvd authoring applications:
Applications - DVD Authoring Tools - openSUSE Forums

It’s much easier, the guy just wants a copy of the dvd, does not have to touch anything.
Use k3B !!! Simply insert the dvd in the drive, click Copy DVD, in the next screen you can check “Only create image”, next Tab where to put the image. Click Start and let k3B do the job. After finish you will have a “yourdvdname.iso” in the folder you told k3B to put it in.
Now insert a blank dvd in the drive, start k3B, select Burn DVD-image to disc, Start and k3B will burn the copy of your dvd.

Thank you for the replies. I think I will try some of those today, and see what happens. I keep trying, but I just cannot get dvd::rip to work.

By the way, I am using gnome. But I suppose I can still try some of the suggestions above.

Wow! I tried using k3b, and that things works like a charm! I got an iso and it appears to be an exact copy of the dvd. I have yet to try to burn the iso using k3b. I will try that soon just to make sure I can do it.

However, I am having some issues while trying to watch the movie from the iso file. How can I get the iso to play starting from the dvd menu? Using mplayer, I can start playing from title 1 using the command

mplayer dvd://1 -dvd-device <isoName>

This starts the movie, but does not bring up the dvd menu. I can use VLC from the command line and start from the menu, but there is no sound at all when I do this.

Hmm, xine seems to do everything correctly from the menu. I guess I will have to play around some more with VLC and mplayer.