DVD image install in Virtualbox

I was trying 15.2 and tumbleweed in Virtualbox.

If I use the install DVD - there is no Virtualbox Guest code and the mouse and keyboard are rather limited and painful to go forward with.

If I install Mint Linux - their DVD have the Virtualbox Guest code in the install kernel and installation is easy.

If you have a network connection during the install, there should be a prompt to enable online repos. The virtualbox guest software should be in those repos.

Virtualbox Guest Additions from openSUSE depends on the version of openSUSE installed as your Guest.
If 15.1, then VBox 6.1 Guest Additions should be installed automatically, does not matter what HostOS is.
If 15.2, unknown at any time whether GA are available and built properly, but report if you have problems anyway.

You can always search for virtualbox guest packages to determine if the packages providing Guest Additions are installed whether they are working properly or not.

If Virtualbox Guest Additions are not working, you <may> need to remove any installed virtualbox guest packages first (I recommend doing so anyway to avoid confusion) and install Guest Additions using the Guest Additions ISO (should be accessible in that Guest’s graphical console as a menu selection). Of course, if you install GA using the ISO, you’ll be manually compiling the kernel modules so require the following dependencies on your system first, the zypper command installs them

zypper in kernel-devel kernel-default-devel gcc make

If what I posted is unclear or you are unable to install Guest Additions this way, post your issue with details.

Ordinarily virtualization related questions should be posted in the Virtualization Forum.


The install is not Virtualbox ready - it does not have the guest additions. So the mouse does not work at all during the install process.

But the installed OpenSUSE 15.2 virtual machine gets the virtualbox guest additions automatically at the install - no need to select to install it.

I suggest you file a bug report about that. Bug reports are how developers learn of these problems.

Since I saw strange behaviour with mouse in VBox 6.1.4 and Leap 15.2 Beta, I tried but was not able to reproduce what is described by the OP.
Tried Leap 15.1 DVD (GA) on VBox 6.0.12 on Leap 15.1 host, mouse (actually touchpad) works as expected.
Tried Leap 15.2 Build 617.1 on the same, mouse works as expected and display works even better, with auto-resizing, full-screen and all, so at least some sort of guest additions should be there.
So it doesn’t seem to me to be a general issue, but will join for testing if there is a bug report.

Have fun with 15.2 :wink:

AFAIK Beta does not really support updates but a series of different releases.
Try downloading a brand new Beta DVD and try again, maybe the VBox GA were fixed in a later release.