DVD drive not mounting

OpenSUSE is not automatically mounting media inserted into my Pioneer 216D DVD burner. Also, K3B detects my drive (as /dev/sr0) but not any media inserted into it - it always reports ‘no medium present.’

The drive was working perfectly under Ubuntu so this is not a hardware fault.

There was no entry in /etc/fstab for my DVD drive so I added the following line and rebooted:

/dev/sr0 /media/dvd udf,iso9660 ro,user,noauto 0 0

However, this did not solve the problem at all. I’m out of ideas, so I would greatly appreciate some opinions on this.

Try this: Yast > Security and Users > User and Group Management > Users > Edit > Details: add ‘cdrom’ and ‘disk’ groups to your user account. You may need to restart your system.

Thanks for the suggestion. Unfortunately, it didn’t seem to fix my problem. Any other ideas?

I’m in the same boat. My DVD drive worked after the initial install and several reboots. I even had a video loaded, I paused it, came back an hour or so later with no system response. I rebooted, no affect. I’ve added the permissions to my profile, still nothing.

IBM T61 Thinkpad DVD RW

Still looking for a solution.

Thanks in advance.

Take a look at this blog. It has additional suggestions:
Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change