Dual Monitor Minssing with Nouveau

I’ve made a bit of a mess.

My Tumbleweed machine was running just fine with Nouveau and giving me a dual monitor display - laptop and external monitor.

I wanted to try out the Nvidia drivers, but initially made a mess, and got it up and running.

But I went back to nouveau.

However now, the external monitor is non-existent as far as the system is concerned.

xrandr is not reporting the attached monitor.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
1920x1080 77.00*

hwinfo reports:

94: None 00.0: 10000 Monitor
[Created at fb.71]
Unique ID: rdCR.EY_qmtb9YY0
Hardware Class: monitor
Model: “Generic Monitor”
Vendor: “Generic”
Device: “Monitor”
Resolution: 1920x1080@77Hz
Year of Manufacture: 0
Week of Manufacture: 0
Driver Info #0:
Max. Resolution: 1920x1080
Vert. Sync Range: 50-90 Hz
Hor. Sync Range: 31-87 kHz
Config Status: cfg=no, avail=yes, need=no, active=unknown

Help greatly appreciated.

OK, I worked out the solution.

  • Uninstall all Nvidia packages
  • rmmod any Nvidia kernal modules
  • delete any Nvidia .conf files in /etc/modprobe.d/
  • reboot

I now have my dual monitor configuration back! :slight_smile:

Be aware that you may run into a “double cursor” if you use xrender compositor (which worked the best for me with lenovo laptops with dGPU).