Dual boot with windows + nic in windows doesn't recoginze cable is plugged


I’ve just installed a brand new hard drive and I wanted to dual boot windows 10 + openSuSE. I first installed windows 10 and everything worked fine, the lan worked and I could browse internet without any issue. I then proceed to install Leap 15.2 and when I logged back into windows my network interface complain about lan cable being disconnected. If I log back into SuSE everything is fine.

So the bottom line is when I installed Linux, the nic in windows stopped recognizing the lan cabled was plugged in.

This is the output of lspci -v

07:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
Subsystem: ASUSTeK Computer Inc. Device 820d
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 19
I/O ports at e800 [size=256]
Memory at fbeff000 (32-bit, non-prefetchable) [size=256]
Expansion ROM at fbec0000 [disabled] [size=128]
Capabilities: [dc] Power Management version 2
Capabilities: [60] Vital Product Data
Kernel driver in use: r8169
Kernel modules: r8169

Any help is appreciated I know for sure that the windows installation is ok and there is no need to update any drivers or anything like that, it just simple stopped working after installing openSuSE.

Thanks in advance![/size][/size][/size]

Try unplugging AC cable for a couple of minutes after shutting down openSUSE. If this is notebook, you need to also remove battery to make sure no power source is present. Then boot Windows - does it see NIC now?

This is the output of lspci -v

Always use “lspci -nn” (in addition to any other flags) - it shows numerical PCI ID which is necessary to reliably identify device.

Plug the cable into another header. Helps with my router.[/size][/size][/size]


Thanks for the tip. That did the trick but it’s only a workaround. As soon as I log into SuSE and try to switch back to windows the problem is there. So definitively something is not right with the linux driver.

I noticed as well that when I boot into suSE and then restart / switch off on the pc, the nic doesn’t recognize the cable is plugged in until the SuSE kernel is booting up.

Probably there are some missalignements with the power management for the nic.

Any ideas?


Thanks for the info, that was the first thing I tried but that’s not the problem, @arvidjaar is pointing in the right direction.


It was not supposed to be a fix, but troubleshooting step. Next step would be to try latest stable or HEAD kernel.




I’m trying booth options with unsatisfactory results.

When using latest stable kernel, the error is still there but when using HEAD the grub bootloader doesn’t show the corresponding option for booting into openSUSE and now I’m trying to get back that option.

Really strange problem.

After repairing the broken system and successfully booted into

jaime@localhost:~> uname -a
Linux localhost.localdomain 5.10.0-rc2-2.g286191a-default #1 SMP Sun Nov 8 22:49:50 UTC 2020 (286191a) x86_64 x86_64 x86_64 GNU/Linux

the error is still present.

Any new ideas ?


If a power off fixes Windows then this is a case that the hardware is not being reset when you switch OS. I have seen this happen in the past but the other way around Linux not seeing NIC after Windows / It may be the BIOS is not properly resetting the hardware on a warm boot.

In this case you really need to open bug report. As the same problem exists in the latest kernel it is likely upstream issue; it still makes sense to try openSUSE bugzilla (simply because kernel maintainers have better knowledge and are usually more responsive), but be prepared that answer will be “report upstream”.

It also makes sense to try earlier kernels. You could try booting Leap 15.1 or Leap 15.0 live images. If problem did not exist in earlier openSUSE kernels, it means regression and has better chance to get attention.

You may try to play with Wake on LAN options; what is current output of “ethtool interface” (as root)