Dual Boot Windows 7

Hi Everyone,
I am trying to do a dual boot with Windows 7 and i am getting the following error below attached https://ibb.co/iajgoahttps://ibb.co/iajgoa

How do i fix it please?



Hi and welcome to the Forum :slight_smile:
Is the Windows install 32 or 64 bit? Seems strange having a /dev/btrfs device, how did you setup the partitioning?

Hardware?? is it a 32 bit machine Leap only comes for 64 now a days.

Also possible some small notebooks have 32 bit EFI and though there are work arounds it is not easy.

Only openSUSE 32 bit is Tumbleweed

Hi Guys,
Thankyou for your quick reply, my installed Windows 7 is 64bit, should i try installing the 32bit version?

Also here is the disk management layout https://i.imgur.com/qvo4aae.png



No the problem may be that the BIOS/UEFI requires 32 bit on that hardware (which you still have not told us)

Out of the box openSUSE does not provide 32 bit grub boot support for EFI booting. But you need to tell hardware for us to know. There are some Asus models that have this weird configuration. Maybe others.

I’m probably contradicting some of the other posts in this thread.

From your disk map, there does not appear to be an EFI partition. So I am doubting that UEFI is involved.

I presume that you are using traditional MBR partitioning (legacy partitioning, MSDOS partitioning), because that’s what Windows requires if there is no UEFI. You have 4 primary partitions, and no extended partition. So the only way to install would be to take over one of those partitions.

I’m guessing that you wanted to install in the first partition shown (the 60.20GB partition). Because that’s the only way it could work without changing the partitioning.

I presume that you are formatting that partition to use “btrfs”. I’m really not sure how that works here. There is supposed to be space for a boot block to install grub to a “btrfs” volume. I’m guessing that is what the grub message is about. Perhaps that boot block needs a “/dev/btrfs” but it was not properly configured by the install. You should be able to go with the other alternative, of installing grub to the MBR. You can set that in the installer, by clicking on “Booting” (or similar wording) on the summary page that you see just before installing actually begins.

It occurs to me that it might be simpler to use “ext4” in place of “btrfs”. On the first partitioning screen, the installer gives a proposed partitioning. There’s something you can click there to change the defaults. Change to using “ext4” for the root file system.

With regards to the BIOS/UEFI, how can i find that out in order to tell you?

Tell us the hardware. Or look up the full specs

If the machine is less then 6 years old it is most likely UEFI based not BIOS based. But a few models have been reported here about UEFI based machines that use 32 bit EFI booting which is not supported. openSUSE supports out of the box only 64 bit EFI booting. Even if the processor is 64 bit. Option is to use Legacy booting ie MBR but all OS’s installed must use the same boot method.

Best thing you could do at this point to get help:

Boot with the installer DVD, but instead of choosing “Install” from the Grub menu, choose the “Rescue System” (or some equivalent name).

When you get a login prompt, type


There is no password, so just hit the Enter key next.
From there, get us the output for:

fdisk -l


parted -l

Note that those are lowercase Ls, not the numeral 1.

That would be a very good starting point.

You was spot on i fixed it with your help. Formatted the 60gig partition to ext4 and then just before the last step of install i clicked on add to MBR and it work.

Thankyou very much for your help :slight_smile: