Dual boot, cannot get to NTFS shares

Hi all,

Still a noob at this! I’ve been running a dual boot setup with Windows 8.1 and OpenSUSE 13.1 for quite a while. I have another internal drive that is NTFS. I’ve been able to read the drive successfully all the while. I run all the updates when prompted. Today, I booted as normal into my OpenSUSE partition, and went to the NTFS partition. I entered my root password, and I get the following text:

An error occurred while accessing ‘Media’, the system responded: The requested operation has failed: Error mounting /dev/sdb1 at /run/media/michael/Media: Command-line `mount -t “ntfs” -o “uhelper=udisks2,nodev,nosuid,uid=1000,gid=100,dmask=0077,fmask=0177” “/dev/sdb1” “/run/media/michael/Media”’ exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount ‘/dev/sdb1’: Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the ‘ro’ mount option.

I’ve attempted to boot into the Windows partition, which I’ve done successfully in the past, and it doesn’t load! I’m not sure where to look nor how to approach this. Can anyone please help direct me?


NOTE: Modified title.

Update on the situation: I’ve found out one of my NTFS formatted drives died (devastated - tons of files on it). I’ve removed the dead drive, and I am not getting the Linux bootloader. I’ve looked on other threads, and one said to run (after booting from a DVD) grub2-install. Well, I boot to the DVD and I am prompted for: 1. Installation, 2. Recovery, 3. Check install media. I’ve tried Recovery and gotten nowhere. I read where I can try an upgrade and not lose any data, but with how this day has gone so far, I’m terrified. Can anyone please help??

Okay, take a deep breath and relax, we will help you with what we can.

First, recovering Grub.

For precise instructions, we need some info.

Boot with the DVD, choose the Recovery or Rescue System option.

It will stop with the line

Rescue login:

Type (without the quotes) “root” then press Enter.

You will now see the prompt, probably in a red font:


Plug in a USB key that is ready to go, wait a couple seconds to be sure it is detected.


fdisk -l

Note that that is a lower case L, not a numeral “1”

This will list your drives and partitions.

If you have a USB key ready to go, it should show in that list

You should be able to figure out which listing is the USB key (sda, sdb, or sdc, or ???)

In the next set of commands, replace the X with the correct letter for your USB key.

Mount the key (This time, it IS the numeral “1”):

mount /dev/sd**X**1 /mnt

Now, run:

fdisk -l > /mnt/fdisk.output

You can then shut down:

shutdown now

Take that USB key and paste the contents of the fdisk.output file here between CODE tags. To get the code tags, in the message posting editor, at the top, second row of icons, to the right, click on the # sign. Your cursor should now be blinking in between a set of CODE tags. Just paste the file contents at that location.

With the information you post, we should be able to give you precise directions to recover your Grub.

Good luck.

Thanks so very much!! Here is the output file contents:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk label type: gpt

#         Start          End    Size  Type            Name
 1         2048      1026047    500M  EFI System      EFI system partition
 2      1032192      1114111     40M  unknown         Basic data partition
 3      1114112      1376255    128M  Microsoft reser Microsoft reserved partition
 4      1376256      2400255    500M  Windows recover Basic data partition
 5      2400256   1035857919  492.8G  Microsoft basic Basic data partition
 6   1934036992   1935263743    599M  Microsoft basic Basic data partition
 7   1935265792   1935982591    350M  Windows recover 
 8   1935982592   1953523119    8.4G  Windows recover Microsoft recovery partition
 9   1035857920   1052643327      8G  Microsoft basic primary
10   1052643328   1157498879     50G  Microsoft basic primary
11   1157498880   1199446015     20G  Microsoft basic primary
12   1199446016   1220409343     10G  Microsoft basic primary
13   1220409344   1934036991  340.3G  Microsoft basic primary

Disk /dev/sdb: 8015 MB, 8015314944 bytes, 15654912 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0xa03aa0e0

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        8064    15654911     7823424    7  HPFS/NTFS/exFAT

I await your response!


I’m not sure if this info will help, but here is what I believe (almost positive) are my partitions (this configuration was recommended to me):

#1 is /boot/efi
#9 is SWAP
#10 is /
#11 is /var
#12 is /tmp
#13 is /home

#5 is my main Windows partition

I hope this helps.


Yes, indeed, it does. I have asked a couple of my friends who are more familiar with UEFI to come take a look at this. I think they should be along shortly.

In the meantime, relax, I think good advice will soon come your way. For best results, answer any questions you are asked, read and follow all directions carefully. I will be watching and chime in when I can help properly.:wink:

Also, post the output of:


Ahhh. Just spotted that you are a Lonestar!

Cool! Now we must make certain we get you some help.:wink:

What is your hardware? Since it’s efi bootable (not sure why the boot flag is set on sdb1 either), can you press an Fn key to get to a boot menu, for example on my HP’s I press F9.

From here can you browse of select ‘efi’ file to boot from? If not can you boot from a rescue system and show the output from

efibootmgr -v

Id sdb the dead drive, or is this a new one?

Good morning! I have some output and an observation. First, if I press F12 (for my Dell computer), I get the boot loader. When the OpenSUSE 13.1 disk is in the DVD drive, that is the only one that shows up, hence the following:

BootCurrent: 0001Timeout: 0 seconds
BootOrder: 0001
Boot0001* UEFI: HL-DT-ST DVD+/-RW GHA2N    ACPI(a0341d0,0)PCI(1f,2)03120a000400ffff0000CD-ROM(1,3ad,22108b)AMBO

Also, while continuing to try to learn about this issue, I noticed other listings had lots of entries in the grub.cfg file. Mine just has the following:

search --fs-uuid --set=root 803be0cc-953e-461a-a913-d275d122efd3set prefix=(${root})/boot/grub2
configfile $prefix/grub.cfg

In comparison with those others I’ve seen, my grub.cfg is rather lacking.

Here is the output from lsblk:

NAME    MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTsda       8:0    0 931.5G  0 disk 
├─sda1    8:1    0   500M  0 part 
├─sda2    8:2    0    40M  0 part 
├─sda3    8:3    0   128M  0 part 
├─sda4    8:4    0   500M  0 part 
├─sda5    8:5    0 492.8G  0 part 
├─sda6    8:6    0   599M  0 part 
├─sda7    8:7    0   350M  0 part 
├─sda8    8:8    0   8.4G  0 part 
├─sda9    8:9    0     8G  0 part 
├─sda10   8:10   0    50G  0 part 
├─sda11   8:11   0    20G  0 part 
├─sda12   8:12   0    10G  0 part 
└─sda13   8:13   0 340.3G  0 part 
sdb       8:16   1   7.5G  0 disk 
└─sdb1    8:17   1   7.5G  0 part /mnt
sr0      11:0    1   4.3G  0 rom  
loop0     7:0    0  35.1M  1 loop /parts/mp_0000
loop1     7:1    0  20.1M  1 loop /parts/mp_0001
loop2     7:2    0  48.6M  1 loop /mounts/mp_0000
loop3     7:3    0  22.4M  1 loop /mounts/mp_0001
loop4     7:4    0   4.1M  1 loop /mounts/mp_0002

I have no idea why, when I ran fdisk -l, that it set the USB stick to bootable. I never made it bootable. That is what the sdb1 listing is.

Anyway, I will continue to be patient. I would prefer to get this grub2 fixed as opposed to upgrading to 13.2 (the other thread I started). Thanks again for the help!


OK, let’s check the efi partition. Boot from the rescue system and then mount /boot/efi (sda1) and see if things are still there…

mount /dev/sda1 /mnt
ls /mnt/EFI/opensuse/

[Should see something like]

MokManager.efi  boot.csv  grub.cfg  grub.efi  grubx64.efi  shim.efi

[if so]

efibootmgr -c -L "opensuse-secureboot" -l "\\EFI\\opensuse\\shim.efi"

efibootmgr -v

[Should see something like]

Boot0002* opensuse-secureboot    HD(2,96800,82000,8aab4d75-f8ce-4691-b094-57bf2f3f20ce)File(\EFI\opensuse\shim.efi)

[if so, see the number in above example 0002, substitute for the output you see]

efibootmgr -n 0002

systemctl reboot

That should now boot into openSUSE, once the system is up, lets fix it;

update-bootloader --reinit
efibootmgr -v

The above should re-add the Windows loader…

I discovered a mistake. It’s actually #6 that is the EFI/opensuse boot partition. So, I followed the commands above, with the exception I substituted mount /dev/sda6 /mnt instead of sda1. Doing that, I get this:

BootCurrent: 0001Timeout: 0 seconds
BootOrder: 0000,0001
Boot0000* opensuse-secureboot    HD(1,800,fa000,6b5880c7-c3ef-4645-8441-c8c64e64a49c)File(\EFI\opensuse\shim.efi)
Boot0001* UEFI: HL-DT-ST DVD+/-RW GHA2N    ACPI(a0341d0,0)PCI(1f,2)03120a000400ffff0000CD-ROM(1,3ad,22108b)AMBO

Note, this has the DVD still in there. Problem is when I remove the DVD, and try to boot from “opensuse-secureboot”, I’m prompted with a “no boot disk installed”. I go into the BIOS, and the first device listed is “opensuse-secureboot”. If I press F12 when it’s booting, I get that option as well. But, it doesn’t boot at all. And now of course, I cannot boot into the Windows OS either.

I’m not panicking…nervous, but not panicking. But we’re not there yet. Is there anything else?


So what is in /dev/sda1 and what is in /dev/sda6? Can you mount them one at a time and show with the ls command?

Sounds like you have a mix of legacy and UEFI boot? Unless you changed the partition type of /dev/sda6?

Thanks! I’ve never gone into the BIOS and changed from UEFI to legacy. This computer has always had Windows 8 (8.1) until I setup the dual boot.

In /dev/sda1, I have:
[li]BOOTSECT.BAK (file),[/li][li]EFI (Folder)[/li][LIST]
[li]Boot (folder)[/li][LIST]

[li]Dell (folder)[/li][li]Microsoft (folder)[/li][/LIST]

[li]System Volume Information (folder)[/li][li]en-us (folder)[/li][/LIST]

In /dev/sda6, I have:
[li]$RECYCLE.BIN (folder)[/li][li]EFI (folder)[/li][LIST]
[li]opensuse (folder)[/li][LIST]

[li]System Volume Information (folder)[/li][/LIST]

I hope we’re not at an impasse. How shall we proceed?

Wow! When the grub loader gets messed up, it really gets messed up. Probably Windows repair had something to do with that.


Interesting, ok lets try this first;

So we just need to set the type back to ef00 on sda6, so boot from the
rescue dvd and run as root;

gdisk /dev/sda
efibootmgr -n 0
systemctl reboot

Else if that doesn’t work, we can copy the opensuse dir over sda1 and redo the efi entry.

That is his USB stick that I gave him earlier instructions to save the output of his commands to while in Rescue console so he could post them here.

… Oh.

And thanks for dropping in here, Malcolm.:slight_smile:


I’m guessing you meant “fdisk” vs. “gdisk”. Anyway, I ran those commands (using fdisk). When I entered ef00, I got a message saying “Type of partition 6 is unchanged: Microsoft basic data”. Once I ran the Systemctl reboot (and had to eject the DVD), came back to the same point…no boot disk found.

Just for giggles, I rebooted with the disk to run those commands again, and after entering “6” above, I entered “L” to list the options. “ef00” wasn’t an option. There were only number options.

You mention copying the opensuse dir to sda1 and redo the efi entry. Will that still allow me to dual boot?

Thanks again as always!

No, he meant gdisk. You need to use that one for these changes on this setup.:wink:

Oh. Well, when I tried to run gdisk, I got a response: -bash: gdisk: command not found :(.



Connect to the internet from the rescue system and install;

zypper in gdisk