Drucker druckt nicht

Hallo zusammen,

seinerzeit zur Installation von 15.4 hatte ich meinen Drucker eingerichtet und erfolgreich eine Testseite gedruckt - alles absolut stressfrei.
Nun wollte ich eine Dokument drucken, jedoch verbleibt dies in der Warteschlange ohne Fortschritt. Über das Webinterface http://localhost:631 habe ich versucht eine Testseite zu drucken, auch ohne Erfolg. Diesen Testauftrag kann ich nun auch nicht mehr löschen: als Meldung kommt nur “verboten”.

Kann mir eventuell jemand dazu helfen?
Sicherlich muss ich noch weitere Infos bereitstellen - bitte sagt mir dazu, welche Befehle ich ausführen muss.

Danke
Frank

Was für ein Drucker, welcher Treiber?

Hallo Sauerland,

ich habe einen HP Laser Drucker.
Die Beschreibung laut YAST: HP Laser 107w, with driver HP Laser 107w, driverless, cups-filters 1.25.0
Falls Du noch mehr Infos benötigt, gib bitte Bescheid.

Viele Grüße
Frank

Anschließen mit USB-Kabel, als root:

hp-setup

Wird der Drucker erkannt?

In Yast2 > Drucker unter “Richtlinien” die “Default”-Richtlinie als Vorgangsrichtlinie konfigurieren. Dann den Drucker in den “Idle/Read/Bereit”-Zustand bringen. Mit dem Druckerwartungsprogramm der eigenen Wahl. Zum Beispiel:

hp-toolbox

> Register “Printer Control”.

Wenn ich hp-toolbox öffne, kommt die Meldung “No installed HP devices found”. Also ist anscheinend der Drucker in der Tat nicht richtig eingerichtet, obwohl YAST etwas anderes sagt und ich beim initialen Einrichten auch eine Testseite erfolgreich gedruckt habe.

Würde nun der Drucker entfernen und wieder hinzufügen, außer jemand hat noch eine andere Idee …

Habe nun den Drucker neu eingerichtet, jedoch ist der Status “Druckerausgabe deaktiviert” und auch der Knopf “Testseite drucken” ist deaktiviert.
Also irgendetwas geht gewaltig schief …

Habe dazu einen Screenshot gemacht, aber entweder kann man keine Bilder anhängen oder ich finde die Option nicht.

Das mal gemacht?

Gerade ausgeführt - ich musste dazu die Option -i anhängen, da er sich über den GUI support beschwert hat.


**laptop:~ #** hp-setup -i 

**HP Linux Imaging and Printing System (ver. 3.21.10)**
**Printer/Fax Setup Utility ver. 9.0**

Copyright (c) 2001-18 HP Development Company, LP 
This software comes with ABSOLUTELY NO WARRANTY. 
This is free software, and you are welcome to distribute it 
under certain conditions. See COPYING file for more details. 

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.) 


-------------------------------- 
| SELECT CONNECTION (I/O) TYPE | 
-------------------------------- 

  Num       Connection  Description                                                
            Type                                                                   
  --------  ----------  ---------------------------------------------------------- 
  0*        usb         Universal Serial Bus (USB)                                 
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect) 

**Enter number 0...1 for connection type (q=quit, enter=usb*) ? **

Using connection type: usb 

**error: No device selected/specified or that supports this functionality.**


Wenn ich 1 auswähle erscheint dieselbe Fehlermeldung

Jetzt habe ich aus purer Ratlosigkeit meinen Rechner in Windows gebootet (habe ein Dualboot-System bzw ein Tripleboot-System mit Kubuntu).
Kaum war Windows gestartet, wurde eine ältere Version meines Dokumentes gedruckt, so als wäre dieses im Drucker-Cache gewesen und konnte zuvor nicht abgearbeitet werden. (Windows hat keinen Zugriff auf dieses Dokument). Jetzt konnte ich auch wieder mit YAST den Drucker hinzufügen und drucken.

Kann man daraus etwas ableiten für die Drucker-Konfiguration unter openSUSE? Möchte natürlich nicht regelmäßig in Windows booten …

Noch eine Idee zur Ursachenforschung: auf meinem Kubuntu-System hatte ich dieses Problem nicht.
Ist es vielleicht zielführend einen diff von den Konfigurationsdateien zwischen dem openSuse und Kubuntu zu machen?