Dropbox, etc. can't work on startup because NTFS drive doesn't mount until password is given


I have a new install of openSUSE 12.2. Dropbox doesn’t work when I boot because I keep my Dropbox folders on another drive that is partitioned NTFS (so I can use the same folders from my winxp boot). When I first load into openSUSE, all my drives other than the installation drive are not accessible until I click on them and enter my password. Then I can use them (or relaunch dropbox and it works fine).

Could someone please tell me how I can get them to mount on startup without having to enter my password?

(I’ve tried changing settings in org.freedesktop.udisks.policy and also udisks2 (changing <allowactive> to yes), but these changes don’t seem to help.

Thank you,


As far as I know, the issue you describe is as much how the Windows PC is setup as is the Samba Setup. Using the global setting Security = Share and using a share that has been opened to all on the Windows users might work. Also, I prefer to browse to shares instead of mounting them every time. At least for a Windows PC, the password is not required until you actually need something off of the remote PC. In fact I am just not a big fan of remote mounting of shares with Samba. For a look at some things I do with Samba, have a look here:

Samba S.W.A.T. - Samba Web Administration Tool Setup for openSUSE: https://forums.opensuse.org/blogs/jdmcdaniel3/samba-swat-samba-web-administration-tool-setup-opensuse-76/


SWAT - Samba Web Administration Tool - Setup & Creation Script - 1.04: https://forums.opensuse.org/blogs/jdmcdaniel3/swat-samba-web-administration-tool-setup-creation-script-1-03-105/

AND for all things Samba, you are not done until you have looked here:

Suse / openSUSE Linux HowTos and Tutorials: openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

Thank You,

What you want is to automount your windows partition on boot, so that Dropbox can automatically sync it. This means read/write access.

You can do this by inserting this line at the end of your /etc/fstab

/dev/sda2         /windows          ntfs-3g    defaults    0    0

replace the following:

  • /dev/sda2 by your windows partition.
  • /windows by an already existing folder. this is where the drive will mount to.

defaults means read/write access for everyone, which might be a security issue for you. You might want to look up “basic NTFS-3G options” for more specific permissions. Once this is done, reboot, and it should be mounted with read/write.

I think the 2nd response was the sort of thing I’m after, but it didn’t work. (I’m not trying to share the drives live, but only using them both from a dual boot; so I’m trying to avoid having Dropbox make 2 copies when one is fine – they’re on a physically separate drive formatted ntfs).

I’m not sure why the fstab changes didn’t do the trick, but when I boot in, Dropbox complains and Dolphin shows a “/” by each drive instead of the symbol that shows it is connected. When I click on any of the drives with the “/” symbol, it asks for the root password. After I enter it, I can access those drives until I reboot. I can relaunch Dropbox and it works with no problem. But it’s a little annoying to have to run through this routine each time I boot.

From what I learned googling for the answer, I suspect it’s a udisk issue, but I tried everything I saw posted and nothing worked.

Please post the result of

cat /etc/fstab

Tell us what your username is when you login on this machine

Can you tell us how your NTFS-partitioned drives are connected to your system?

WAIT. It did work.

When I first tried it, my session was saved in the old directories. When I made the fstab, I set up new mount points under /media/WinXPdrive and other such names. So when I booted in, Dolphin complained about not finding stuff and so did Dropbox, so I thought it didn’t work. The next time I logged in, I appreciated what had actually happened. Now I have 5 physical drives working (and all their partitions).


(I hope this post helps someone else, I was googling all over (and had tried some other things with modifying fstab that didn’t work). The udisk modifications didn’t work, so it was a tiring chase until you just gave me the simple fstab line, which got me to try it again (even though I thought I had tried fstab already). This time it worked. I’m not sure what I messed up last time–perhaps I also had a session saver illusion then too.

Thank you!

Can I ask a small followup?

Dolphin lists the drives on the left. Some have names that are useful to me like “WinXPdrive” some just say “40.0 GiB Hard Drive”. Is there a way I can get them all to have names I want? (they don’t seem to just name themselves after my mount points)

Use a Live CD of Gparted or Parted Magic and add Volume Labels

Ignore the boot flag part of this video
Should give you the idea