[drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.

Hello,

during booting of a PC running openSuSE 13.1 since some days I get this error message.

[drm:drm_pci_agp_init] *ERROR* Cannot initialize the agpgart module.

.
The PC continues to boot but ends up in text mode (init 3). If I login as root and start the X11 with

init 5

then X11 is started and I don’t discover any further mistakes but I would like that the computer is booting completely and waiting for the graphical log-in with KDM directly and not going first into text mode.

There are articles in the internet to repair this bug but none of them help. One for Linux Arch suggested to blacklist the drm driver but although I extended the list in

/etc/modprobe.d/50-blacklist.conf

with the drm entries this did not help.

Do You have any ideas?

Thanks

honterus0

My Hardware:
Asrock Q1900M Mainboard with integrated Celeron J1900 CPU, GPU is inside in the CPU. (Intel HD Graphics)

It is possibly being loaded in the “initrd” file. You could try setting “NO_KMS_IN_INITRD” to “no”. I think you can do that with
Yast –> /etc/sysconfig editor –> kernel

or you can directly edit the “kernel” file in “/etc/sysconfig”.

You then need to run “mkinitrd” before the change takes effect.

Oh, and 13.2 will change how that is handled, but blacklist together with rebuild of “initrd” might be enough in 13.2.

Hello,

Thanks for the fast response.

I did ALMOST as You suggested and used the NO_KMS_IN_INITRD = yes. It was set to “no” (default in openSuSE 13.1) so I tried the opposite. Now, I have the impression that the drm modules are loaded later because in the dmesg they appear 2 seconds later then before. However, they are still loaded and although they are in the blacklist as well the system still loads them.

So unfortunately it did not help.

I think since this server is running almost always I will live with this minor blemish.

If You have other suggestions I will try them.

Thanks anyway.

honterus0

Indeed, I had that backwards. Sorry about that.

I don’t have other suggestions at the moment.