driver intallation rt2870 - opensuse 11.1

I’m studying and working through the process @ SDB:ASUS WL-160N USB Wireless Adapter - openSUSE

Although I don’t have the WL-160N adapter, the Linksys USB adapter appears to use the same rt2870 driver. My assumption is that adapter brand name doesn’t matter.

I’m through the “Driver Configuration and Build”, but am stuck on the install kernal source gcc reference.

Thanks in advance for any direction on next steps.

I’m through the “Driver Configuration and Build”, but am stuck on the install kernal source gcc reference.
means you need to go to YaST - software management & find & install them.


Andy, thanks!

I went through the process that you recommended, but the correct package repositories are not present in “default” 11.1 Do I need to go here Add Package Repositories to YaST - openSUSE to download what is necessary?

Thanks in advance for your ongoing assistance!

Kernel sources,gcc/gcc++ & kernel headers,etc, should be on your install dvd.Once installed you will need to update them as well.Unless ----- you installed via cd,then, all of this will require additional repo’s. If you don’t have the dvd,add this repo & disable the cd selecting which arch you have


Andy,thanks! Since I downloaded the CD version of 11.1, and have it installed, I’ll need to get the 11.1 add-on package repository.
You referenced “selecting which arch you have”. Please explain what that means.

Thanks again in advance for your support!

arch = architecture i.e. i586,i686,ppc x86_64 etc of your p.c./laptop


Andy, thank you for answering my questions. I’m obviously very new to linux, but not completely “computer” illiterate. I appreciate your patience!!

No problem, we are here to help as much as we can


Thank you. OK, I’ve downloaded arch= i686, in folder i686 and have the folder and contents on a cd. YaST was opened and I tried to figure out how to install the contents in either software management, or software repo’s. But, I’m stuck.
If you have the time, please indicate next steps.

Thanks again for your help an support.

solved - once I got the network configured and got online, all repo’s. seem to have been downloaded and installed.

as deltaflyer may be getting some hard-earned rest, egrpioneer,

do you have a wired internet connection; that is often recommended if at all physically possible, till one can cut the wires and fly wireless;

if it were, then if you had selected gcc etc, YaST might well have installed them, as you selected them;

so you now want to install Kernel sources,gcc/gcc++ & kernel headers,???

but sounds like you have downloaded them … as rpm files …?? into a directory possibly called Download … or somesuch …

if you then want to install them, you would now make sure YaST is closed … but right-click on the files one by one by opening the directory they are stored in … and

by right-clicking selecting open with software installer; that will open YaST in another form; and it should close after each file is installed; if not, it should be closed, as only edition of YaST is tolerated at any one time;

that is my suggestion; I hope it is correct, and works for you

Does this mean you are now up & running ? If so,Well done for persevering & congratulations. Now enjoy :slight_smile:


Andy, yes, “all systems go”! I appreciate your support.

Thank again!!!

Forgive me if I am hijacking this thread, but it seems very similar to my situation.

Here is where I am. I have edited the to y in both places. I have downloaded using YaST everything I thought I needed (gcc, make, gcc for c++, kernel-headers, kernel-source)

When I go $sudo make, I get :

make -C tools
make[1]: Entering directory `/home/cloud9ine/Desktop/2008_0925_RT2870_Linux_STA_v1.4.0.0/tools'
gcc -g bin2h.c -o bin2h
gcc: error trying to exec 'as': execvp: No such file or directory
make[1]: *** [all] Error 1
make[1]: Leaving directory `/home/cloud9ine/Desktop/2008_0925_RT2870_Linux_STA_v1.4.0.0/tools'
make: *** [build_tools] Error 2

Looks like the first gcc from the make is hitting an issue. I am guessing this has something to do with the versions of something? All help is appreciated.