Driver for rtl8153 usb ethernet

I’m looking for the driver for the rtl8153, which belongs to the rtl8152 family. I have found: and

but it says

There is no official package available for openSUSE Leap 15.3

How do I get the driver?


Is this an USB to Ethernet Dongle?


How do I get the driver?

Its inside the kernel:

stephan@laptop:~> /usr/sbin/modinfo r8152
filename:       /lib/modules/5.3.18-59.10-default/kernel/drivers/net/usb/r8152.ko.xz
version:        v1.09.11
license:        GPL
description:    Realtek RTL8152/RTL8153 Based USB Ethernet Adapters
author:         Realtek linux nic maintainers <>
suserelease:    SLE15-SP3
srcversion:     A895F035F941525FE192C00
alias:          usb:v2357p0601d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v2357p0601d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v0955p09FFd*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v0955p09FFd*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v13B1p0041d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v13B1p0041d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFpA387d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFpA387d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp721Ed*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp721Ed*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp7214d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp7214d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp720Cd*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp720Cd*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp7205d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp7205d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp3069d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp3069d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp3062d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp3062d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v17EFp304Fd*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v17EFp304Fd*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v04E8pA101d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v04E8pA101d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v045Ep0927d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v045Ep0927d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v045Ep07C6d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v045Ep07C6d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v045Ep07ABd*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v045Ep07ABd*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v0BDAp8153d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v0BDAp8153d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v0BDAp8152d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v0BDAp8152d*dc*dsc*dp*icFFisc*ip*in*
alias:          usb:v0BDAp8050d*dc*dsc*dp*ic02isc06ip00in*
alias:          usb:v0BDAp8050d*dc*dsc*dp*icFFisc*ip*in*
depends:        usbcore,mii
supported:      yes
retpoline:      Y
intree:         Y
name:           r8152
vermagic:       5.3.18-59.10-default SMP mod_unload modversions 
sig_id:         PKCS#7
signer:         SUSE Linux Enterprise Secure Boot CA
sig_key:        ED:87:85:B7:8F:FC:12:7E
sig_hashalgo:   sha256
signature:      08:49:03:DB:47:90:1C:71:AD:01:77:A9:45:66:8D:33:25:A3:22:A4:

After some exploration (ie google) i have found that there’s another one that is supposed to work better:

because the one from the kernel hangs and kills networkmanager, then I can’t shutdown anymore until the 4sec power off


We need:


And the journal log from boot on susepaste:

journalctl -b

RTL8153 worked OK with Leap 15.0 - 15.1.

usbcore: registered new interface driver r8152
usbcore: registered new interface driver cdc_ether

  • which driver it will use?

It’s well supported by the Linux kernel, but the default r8152 module is rarely used, the generic cdc_ether driver is loaded instead. There’s another problem, sometimes the r8152 module shipped with kernel can’t even detect newer variants of the RTL8153 chip.

Hi, I just wanted to report that I have the same issue. I had it in 15.2 and 15.3. Any help is welcome.:slight_smile:

Install hwinfo and post:

/usr/sbin/hwinfo --netcard

Use Code-Tags:

Ok, so this is it:

06: PCI 300.0: 0282 WLAN controller
  [Created at pci.386]
  Unique ID: PL6s.XdAXaWs3LQ2
  Parent ID: mvRC.zHLxyn_yu18
  SysFS ID: /devices/pci0000:00/0000:00:1d.2/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Lite-On Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter"
  Vendor: pci 0x168c "Qualcomm Atheros"
  Device: pci 0x0042 "QCA9377 802.11ac Wireless Network Adapter"
  SubVendor: pci 0x11ad "Lite-On Communications Inc"
  SubDevice: pci 0x08a6 "Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter"
  Revision: 0x31
  Driver: "ath10k_pci"
  Driver Modules: "ath10k_pci"
  Device File: wlan1
  Features: WLAN
  Memory Range: 0x94000000-0x941fffff (rw,non-prefetchable)
  IRQ: 132 (9986 events)
  HW Address: 74:df:bf:94:b1:9b
  Permanent HW Address: 74:df:bf:94:b1:9b
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7 5.745 5.765
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v0000168Cd00000042sv000011ADsd000008A6bc02sc80i00"
  Driver Info #0:
    Driver Status: ath10k_pci is active
    Driver Activation Cmd: "modprobe ath10k_pci"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #18 (PCI bridge)

12: PCI 400.1: 0200 Ethernet controller
  [Created at pci.386]
  Unique ID: rBUF._Qz41NZf11E
  Parent ID: eEx1.UiHhRM6gQQ8
  SysFS ID: /devices/pci0000:00/0000:00:1d.3/0000:04:00.1
  SysFS BusID: 0000:04:00.1
  Hardware Class: network
  Model: "Acer Incorporated [ALI] Acer Aspire E5-575G"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8168 "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
  SubDevice: pci 0x1094 "Acer Aspire E5-575G"
  Revision: 0x12
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: eth0
  I/O Ports: 0x3000-0x30ff (rw)
  Memory Range: 0x94204000-0x94204fff (rw,non-prefetchable)
  Memory Range: 0x94200000-0x94203fff (rw,non-prefetchable)
  IRQ: 19 (no events)
  HW Address: 54:ab:3a:a6:3a:39
  Permanent HW Address: 54:ab:3a:a6:3a:39
  Link detected: no
  Module Alias: "pci:v000010ECd00008168sv00001025sd00001094bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

28: USB 00.0: 0200 Ethernet controller
  [Created at usb.122]
  Unique ID: Ykcw.pPU9FHDlTRC
  Parent ID: Zj8l.h6VbFfok0SF
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb2/2-4/2-4.3/2-4.3:1.0
  SysFS BusID: 2-4.3:1.0
  Hardware Class: network
  Model: "Realtek RTL8153 Gigabit Ethernet Adapter"
  Hotplug: USB
  Vendor: usb 0x0bda "Realtek Semiconductor Corp."
  Device: usb 0x8153 "RTL8153 Gigabit Ethernet Adapter"
  Revision: "31.00"
  Serial ID: "001000001"
  Driver: "r8152"
  Driver Modules: "r8152"
  Device File: eth2
  HW Address: 00:e0:4c:69:04:1c
  Permanent HW Address: 00:e0:4c:69:04:1c
  Link detected: yes
  Module Alias: "usb:v0BDAp8153d3100dc00dsc00dp00icFFiscFFip00in00"
  Driver Info #0:
    Driver Status: r8152 is active
    Driver Activation Cmd: "modprobe r8152"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #25 (Hub)

post as root:

journalctl -b | grep -Ei 'firm|815|eth'

I’m the original poster. Doing an upgrade from leap 15.2 (which the usb ethernet was not working) to leap 15.3 though a zypper dup did not help with having the usb ethernet working.

But after “too many problems” I bit the bullet (full backup), brand new install of 15.3 and it works w/o any problem. Something/drivers must have been carried over from the 15.2, but I’m guessing…

You can test it by downloading the iso, burning it to a usb stick and boot from it.

It is a bit too long, so I posted to pastebin. I also changed my hostname with “{myhostname}”.

Thank you for the information. I would not like to have to perform a new install, but I’ll try with a live image. Anyway, I would like to solve this issue instead of a new install.

I think the connection is there:

Sep 22 09:02:55 {myhostname} NetworkManager[2039]: <info>  [1632294175.0390] device (eth2): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Sep 22 09:02:55 {myhostname} NetworkManager[2039]: <info>  [1632294175.4350] device (eth2): Activation: successful, device activated.
Sep 22 09:02:55 {myhostname} NetworkManager[2039]: <info>  [1632294175.5503] policy: set 'Conexión cableada 2' (eth2) as default for IPv4 routing and DNS

This are the last from your journal.

Yes, it constantly comes and goes. I lost connection, then recover it, the lost it again, then recover it. I can provide longer journal, I just call the command when there was only one disconnection and reconnection.

For Leap 15.3 check if these packages are installed: kernel-default-optional and kernel-default-extra.
And you need 2 repos from SLE for Leap 15.3.


LANG=C zypper se kernel-default

Yes, it seems like they are installed.

~> LANG=C zypper se kernel-default 
Loading repository data... 
Reading installed packages... 

S  | Name                           | Summary                                                       | Type 
i+ | kernel-default                 | The Standard Kernel                                           | package 
   | kernel-default                 | The Standard Kernel                                           | srcpackage 
   | kernel-default-base            | The Standard Kernel - base modules                            | package 
   | kernel-default-base            | The Standard Kernel - base modules                            | srcpackage 
   | kernel-default-base-rebuild    | Empty package to ensure rebuilding kernel-default-base in OBS | package 
i+ | kernel-default-devel           | Development files necessary for building kernel modules       | package 
i  | kernel-default-extra           | The Standard Kernel - Unsupported kernel modules              | package 
   | kernel-default-livepatch       | Metapackage to pull in matching kernel-livepatch package      | package 
   | kernel-default-livepatch-devel | Kernel symbols file used during kGraft patch development      | package 
i  | kernel-default-optional        | The Standard Kernel - Optional kernel modules                 | package

Maybe I should have kernel-default-base installed?

I also ran this, just in case:

~> LANG=C sudo zypper inr 
Loading repository data... 
Reading installed packages... 
Resolving package dependencies... 
Nothing to do.

So yesterday it worked perfectly. Today I am having problems again. Maybe I should re-install opensuse 15.3 from scratch but it is a bit painful to re-install all programs/packages and so on. It will have to wait until Christmas I think.

EDIT: it seems that after disconnecting the USB-C and connecting back again, it works perfectly.

Not really working perfectly, it drops intermitently but with less frequency than before.

Today I connected the ethernet cable to the adapter, then the adapter to my laptop’s USB-C port. The adapter has some USB 3 ports that I usually use, but today I have not used. All working. Maybe connecting several things is “too much” for my adapter? I’ll do more experiments.