Drive mount problems at startup.

Hello. Today I made the update from Leap 15.3 to 15.4 on my PC(I already made the update on my laptop), but there is something wrong every time I reboot the system.

I need to explain my disks setup first. I have 4 drives on my PC. 2 SSD(one for Windows 10 and the other for Opensuse) and 2 HDD for data storage, all SATA. The setup look like that when I first installed the system, and is the same even before the update.

  1. Adata (/dev/sda) [Opensuse]
  2. Kingston (/dev/sdb) [Windows 10]
  3. WDC (dev/sdc) [Data]
  4. Toshiba (dev/sdd) [Data]

So I installed Leap, boot windows to see if the dual boot setup was fine, have created the mount folders for my data drives(I never mount the windows drive to avoid messing with W10) on /mnt to make things more comfortable to use, config the /etc/fstab using the UUIDs and all and everything was work fine. After some two or three reboots, i got this screen asking for permission to mount my Windows drive. And after another reboot, I get the same screen, but with my Kingston drive identified as the /dev/sdd drive.

I did more reboots and every time the disks have another order, but the partitions UUIDs don’t change, with allowed me to keep accessing the other drives.

So, there are two questions: How I can get the system to stop asking for mount my W10 drive and why the order of my disks change at every reboot? I think that one thing leads to another.

Thanks for your attention.

You have to set the noauto flag in your fstab for the drives/partitions which you don’t want to automount at boot.

I try to add a block on /etc/fstab. I don’t know was doing right, but this parameter don’t work.

UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /                       btrfs  defaults                      0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /var                    btrfs  subvol=/@/var                 0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /root                   btrfs  subvol=/@/root                0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /home                   btrfs  subvol=/@/home                0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=9409ebcb-905d-4f87-8fd4-08fdd4eb56aa  swap                    swap   defaults                      0  0
UUID=7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  /.snapshots             btrfs  subvol=/@/.snapshots          0  0

UUID=7934d458-d425-4ffb-a0ab-a9a1493dcb14 /mnt/L ext4 defaults 0 0
UUID=CC9A545F9A5447DA /mnt/G ntfs defaults 0 0
UUID=5C0EEA5F0BCBE617 /mnt/R ntfs defaults 0 0
UUID=32D823B2D8237371 /mnt/P ntfs defaults 0 0

#Windows 10 partition
UUID=F2484AAF484A7301 none ntfs defaults, noauto 0 0

I’m doing something wrong?

Remove that space between the “,” and the “noauto”.

I think so. You have 7 items. My entries work:

UUID=f5177cae-4082-44ed-9471-b99030f06866  /HDD                    ext4   user,noauto                   0  0 
UUID=6914-84F3                             /GARMIN                 vfat   user,noauto                   0  0 
UUID=0267-906F                             /GARMIN-KART            vfat   user,noauto                   0  0 
LABEL=FR735                                /FR735                  vfat   user,noauto                   0  0 
UUID=2f0030b8-7257-4cba-be3e-b33154cda052  /WD25                   ext4   user,noauto                   0  0


UUID=F2484AAF484A7301 /somewhere ntfs noauto 0 0 

Change it to:

UUID=F2484AAF484A7301 none ntfs noauto 0 0

The option “defaults” is a placeholder, unnecessary if using any other option. It’s actually the space between “,” and “noauto” that caused your problem. Space(s) between options cause options after the first to be ignored, if not invalidate the whole line.

Thank for the answers. Now I have a better understand of how the /etc/fstab works. Unfortunately, none of that changes solved the problem. The system still ask for a password and is messing with my disk positions.

Show the mess as follows:

**erlangen:~ #** journalctl -b -u polkit.service -u udisks2.service -o short-monotonic  
    8.183528] erlangen systemd[1]: Starting Authorization Manager... 
    8.184000] erlangen systemd[1]: Starting Disk Manager... 
    8.187071] erlangen polkitd[1210]: Started polkitd version 0.120 
    8.188486] erlangen polkitd[1210]: **Loading rules from directory /etc/polkit-1/rules.d**
    8.188516] erlangen polkitd[1210]: **Loading rules from directory /usr/share/polkit-1/rules.d**
    8.189238] erlangen udisksd[1211]: **udisks daemon version 2.9.4 starting**
    8.191086] erlangen polkitd[1210]: **Finished loading, compiling and executing 6 rules**
    8.191321] erlangen systemd[1]: Started Authorization Manager. 
    8.191365] erlangen polkitd[1210]: **Acquired the name org.freedesktop.PolicyKit1 on the system bus**
    8.293921] erlangen systemd[1]: Started Disk Manager. 
    8.305541] erlangen udisksd[1211]: **Acquired the name org.freedesktop.UDisks2 on the system message bus**
   18.725875] erlangen polkitd[1210]: **Registered Authentication Agent for unix-session:3 (system bus name :1.33 [/usr/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)**
   19.094032] erlangen udisksd[1211]: **Mounted /dev/nvme0n1p3 (system) at /TW-test on behalf of uid 1000**
 1658.134377] erlangen udisksd[1211]: **Mounted /dev/sda1 (system) at /HDD on behalf of uid 1000**
 1766.074214] erlangen udisksd[1211]: **Cleaning up mount point /HDD (device 8:1 is not mounted)**
[10341.230355] erlangen udisksd[1211]: **Mounted /dev/sda (system) at /FR735 on behalf of uid 1000**
[10927.670908] erlangen udisksd[1211]: **Cleaning up mount point /FR735 (device 8:0 no longer exists)**
[10927.676361] erlangen udisksd[1211]: **Error cleaning up mount point /FR735: Error unmounting: Command-line `umount -l '/FR735'' exited with non-zero exit status 32: umount: /FR735: nicht eingehängt.**
[10927.676690] erlangen udisksd[1211]: **Cleaning up mount point /FR735 (device 8:0 no longer exists)**
**erlangen:~ #**

Check .config/kded_device_automounterrc for unwanted sections and delete them. See also

Well, I was trying to solve other problem and, by pure accident/luck, maybe had fixed all. I was trying to fix a issue with the KDE filepicker, so I change to the KDE repositories. And after that, the system stops asking for a pass to mount my W10 drive and after many reboots, the disk order keeps the same.

lsblk -f 
NAME   FSTYPE FSVER LABEL                  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS 
├─sda2 btrfs                               7f5d6189-b3b1-4e19-aba4-2e2c6e0712bb  176,8G    20% /var 
│                                                                                              /srv 
│                                                                                              /usr/local 
│                                                                                              /tmp 
│                                                                                              /root 
│                                                                                              /opt 
│                                                                                              /home 
│                                                                                              /boot/grub2/i386-pc 
│                                                                                              /boot/grub2/x86_64-efi 
│                                                                                              /.snapshots 
│                                                                                              / 
└─sda3 swap   1                            9409ebcb-905d-4f87-8fd4-08fdd4eb56aa                [SWAP] 
├─sdb1 ntfs         Reservado pelo Sistema CCDC3DA8DC3D8DA8                                     
├─sdb2 ntfs                                F2484AAF484A7301                                     
└─sdb3 ntfs                                58CE6547CE651E8E                                     
├─sdc1 ntfs         Games_TS               CC9A545F9A5447DA                      259,4G    57% /mnt/G 
└─sdc2 ntfs         Programas_TS           32D823B2D8237371                      417,3G    67% /mnt/P 
├─sdd1 ext4   1.0   Lex_WD                 7934d458-d425-4ffb-a0ab-a9a1493dcb14  498,1G    60% /mnt/L 
└─sdd2 ntfs         Rod_WD                 5C0EEA5F0BCBE617                      168,1G    60% /mnt/R 

So, maybe was a KDE bug?

Sorry for the inconvenience, and thanks for all the help and patience.

Possibly KDE settings are wiped out during install of new KDE, or new KDE uses another settings.
If you will mount new drive, you can get the same issue.