DRI crashes radeon driver

Hi forum,

I recently installed opensuse 12.1 after a long time with Ubuntu. This box is pretty old, I have a Radeon 9600 XT that I was using with the radeon driver in Ubuntu.
While running the livecd I could never get a gui. It booted me to the command line and I proceeded with the installation in text mode. The hard drive was wiped according to the installer. After booting up I still wasn’t able to get gdm to run and did a couple of things:

  1. edited /etc/permissions.local to uncomment the line:
/usr/bin/Xorg             root:root              4711

and run the command:

SuSEconfig --module permissions
  1. enabled the radeon driver by editing the file /etc/X11/xorg.conf.d/50-device.conf:
# Having multiple "Device" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.

Section "Device"
  Identifier "Default Device"

  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-VGA-0" "Default Monitor"


Section "Module"
  Disable   "dri"
  Disable   "dri2"

Now I am able to boot to gui but due to disabling DRI I don’t have hardware acceleration and therefore cannot experience gnome 3. If I enable dri2 it still works but as soon as I enable dri I get the crash with “Caught signal 4” message.
Any ideas?

Here are the logs
SUSE Paste
SUSE Paste
SUSE Paste

Thanks in advance