Download a 4.2 GB iso image ando now a 2.0 GB image

Yesterday I download the suse 11.1 iso image. It was a 4.2 GB file. I burned it into a DVD and today I started the installation. I didn’t realize that the DVD when I write the iso was bad, and the checksums were different one from the original. I didn’t install 11.1 because the disk was broken. And I had no Operating sistem at all, as the install process, formated all my disc,

I decided to install suse 9.3 to download again suse 11.1, but I found that instead of downloading 4.2 GB, it’s downloading 2.0 GB.

Does anybody have an explanation to this ?

Are you writing to a FAT filesystem by any chance?

And it’s not impossible for some SUSE 9.3 programs to not be able to handle large files, it is so old. What are you using to download? Best would be aria2, if you can compile it from source.

I am using FAT system.

I tried to download directly from Firefox.

In Suse 11.0 the iso file was 4.2 GB and in 9.3 is 2.0 GB.

I will install 11.0 again and try to download 11.1 from there. I think is the only solution. (don’t have any sense, but… what can I do ?)

thanks for the feedback

Can you not write it to a FAT file system? Why are you using FAT? Is there not enough space on the native Linux filesystem? Linux filesystems have no problems with files the size of DVD images.

I’m not writing to a FAT file system. I’m only writing to my hard disk. LEt me tell you all the story to make it clear:

A few days ago I had suse 9.3 on my computer. I waht to upgrade my system and I installed suse 11.0. Until this everything was ok. Except for the bugs that 11.0 has, but nothing too serious.

The 11.0 started to give more and more bugs and the most bug I had is that the updater for the fixex was broken so, one by one programs started to a end-running.

I decided then to upload to 11.1, for 2 reasons:

  1. The 11.0 was no very stable
  2. I need more camera controllers thant 11.1 had and 11.0 no.


  1. The first download was on Opera browser. Sometimes I use to pause the download, when I turn off my computer, and the, when I turn on, resume it. Well, then, when it was 1.5 GB to 4.2 GB the dowonload has broken. And a message appears that says that he (the browser) couldn’t resume that download.

  2. Was on firefox. All at once, without pauses. 12 hours downloading the file, it was 5 seconds, 4 seconds, 3, 2, 1, and an error message appears: "Unable to write in “…/download” directory. Choose another. But the file has gone. I had to download it again.

  3. Again, on firefox, downloading in other directory. Download was (apparently) wright. I burn taht file as an iso image on dvd an decided to install. But when I tried to install the file had a bad checksum, so I couldn’t install it.

At this point, I thogth that maybe the files I try to download from 11.0 were corrupt or couln’t write it to the disk because 11.0 had bugs, that can be fixed, because the updater was broken.

I install 9.3 again and try to download the file (suse 11.1 iso) from there and I found out that the file is 2.0 GB, instead of 4.2 GB. Of course I didn’d download it.

Now I am with 11.0 again trying to download 11.1 file so then install it.

Thanks for for your time, and for read all this, (if you did)

regards :wink:

I don’t suppose you have any other OS handy? You could download and burn on say Windows provided you use a good download manager, like downthemall, or aria2 but not IE.

But if you have to install an OS to get started, yeah, might as well start with 11.0 instead of 9.3. But do use a good download manager. The howto on suggests aria2.

The OS or file system should not make any difference, or at least AFAIK the warnings about downloading I keep seeing are inaccurate(unless you’re downloading a file larger than maybe 120gb then it might be an issue)…

But, some applications can be limited.

See the Thread soliciting addendums for the SuSE 11.1 sticky

Suggestions for openSUSE-11.1 Newbie Installation stickie?

I contributed my opinion and recommendation to use the Torrent download which should be foolproof 99%+ of the time. Using this method, it should not matter what OS or file system you’re using. In particular I note that properly used, a Torrent application is supposed to automatically checksum each chunk downloaded **and **the final file re-constructed.

Note that if you already have a partially downloaded file one poster opined that you can use Torrent to repair and continue the file download (I can’t vounch for the procedure).


I don’t know how to use big torrent. I am downloading from opera again without any pauses.

There is a limit on FAT filesystems so it does matter for that.

Well finally…

I am in linux 11.1

Thanks to all your feedback. I am very greatfull

have fun

My apologies. Yes, I am now reminded that there is a 4GB file size limit for FAT32.