Downgrade to GNOME 3.4


I installed GNOME 3.6 (by mistake) by this repo:

zypper ar -f Index of /repositories/GNOME:/STABLE:/3.6/openSUSE_12.2 gnome3

Now I want to downgrade to 3.4.
So, I removed the repo and ran:

zypper dup

But that did not work. What should I do?


How did it not work?

Make sure you have just the 4 official repos

su -
zypper dup

should work

But tell me, was your original install done with a CD or DVD

Tell me the 4 official repos.

I installed using Live USB KDE (CD).

Or shall I add this repo?:
zypper ar -f Index of /repositories/GNOME:/STABLE:/3.4/openSUSE_12.2 gnome3


I think there is a ‘dup’ bug in the CD version, your mention of a problem is serving to confirm this.

That repo you mention does not exist

If you can login to kde
Open Yast > Software Management
see this:
BUT choose unconditionally option

On 10/13/2012 07:26 AM, americast wrote:
> su
> zypper dup

perhaps this problem can be solved simply by fully becoming root with

su -     <good, this does it right
su       <bad, this does not change to root's environment

both will switch user powers/permissions to root, but the first one
also switches the environment to root–which is (sometimes? often?
always?) needed for zypper operations…

read more here and in man su

dd [earlier, known as ‘Palladium’]

Thanx! It solved my problem.

Thanx to you all. All of you are very helpful.

Thank You!!!

I did an upgrade(not by mistake)to Gnome 3.6 once,didn’t logged in,so I downgraded with the same “formula”,I ended with a pretty unclean system,so I reinstalled!

I installed GNOME extension Gmail notifier. A keyring was created and I have to enter its password everytime I log in to my user (It also hangs the pc for a minute or so and is very annoying). Can you tell me any software using which I can manage my keyring and remove the password???


How do I edit the startup applications?


to edit start up, in a terminal do:


Thanx! It worked…any idea about keyring???

Thank You.

Did it! In the home folder there is a folder .gnome2. There’s a folder keyrings in it, I deleted all its contents and my keyring got deleted. I reset my keyring and left the password blank and now my Suse is running perfect!!

Thanx to you all.