Doubts in installing the property ATI driver

I have a Dell Laptop Studio 1735 with an ATI Radeon HD3650 installed and OpenSuse 11.3.

The other features are:

Linux kernel
KDE 4.4.4 release 3

2D Driver: radeonhd
3D Driver: swrast (no 3D Acceleration) 7.8.2

My intention is to install the property driver as showed in the following link

Upgrading ATI driver with atiupgrade

But before, I would like to ask you few questions, because even after having read very carefully the post, I have some doubts:

  1. Do I have to run the script in X or KDE?

  2. Every time I updated the kernel (using the online updating for example), I understood that I must recompile the module fglrx.ko, with the script at the following address:

automatically recompile kernel modules after kernel update

Or I will get a lof of video issues. The file fglrx.ko will be created in the following path:


  1. I must be sure that in the file /etc/X11/Xorg.conf, the parameter “Driver” must be setup to “fglrx” and not “radeonhd”.

Unfortunately, in my computer this file does not exist, what I found is /etc/X11/Xorg.conf.install and as I reported below there is no trace of a “Driver” parameter.

Section "Device"
  Identifier "vboxvideo"
  Driver  "vboxvideo"

Section "Screen"
  Identifier "vboxvideo"
  Device "vboxvideo"

Section "Device"
  Identifier "vmware"
  Driver  "vmware"

Section "Screen"
  Identifier "vmware"
  Device "vmware"

Section "Device"
  Identifier "cirrus"
  Driver  "cirrus"

Section "Screen"
  Identifier "cirrus"
  Device "cirrus"

Section "Device"
  Identifier "fbdev"
  Driver  "fbdev"

Section "Screen"
  Identifier "fbdev"
  Device "fbdev"

Section "Device"
  Identifier "vesa"
  Driver  "vesa"

Section "Screen"
  Identifier "vesa"
  Device "vesa"

Section "ServerLayout"
  Identifier "Layout"
  Screen  "vboxvideo"
  Screen  "vmware"
  Screen  "cirrus"
  Screen  "fbdev"
  Screen  "vesa"

As you can see there is no “Driver” parameter. Is it a problem?

  1. In the case something will go wrong, can I roll back to my previous driver?

  2. Do I always type the command atiupgrade - - initial, the first time I perform the installation?

Thank you in advace for any help yo will give me, and please feel free to ask me anything you need to advice me better.



KDE is one of the different desktop environments used under X, so it is X. You cannot run atiupgrade in X and it won’t run if you are in X. Yo have to boot in runlevel 3 (console mode) and make sure you have an internet connection at this point.

Using modautocompile is not necessary anymore for fglrx. Catalyst now comes with a service /etc/init.d/boot.fglrxrebuild which rebuilds the module after a kernel update. Though you can still use modautocompile for other kernel modules which don’t get recompiled automatically.

This is what the following command executed at the end of atiupgrade does:

/usr/bin/aticonfig --initial=check

If a fglrx section is missing in /etc/X11/xorg.conf, it will then be added by

/usr/bin/aticonfig --initial

Don’t worry about that. A minimal one should be created in this case.

atiupgrade will deinstall a previous installed fglrx driver. But it won’t touch radeonhd. Even if you installed fglrx sucessfully, you can still use radeonhd anytime by changing the driver in /etc/X11/xorg.conf.

You certainly mean aticonfig --initial. It is ran by atiupgrade. You don’t need to do it, assuming atiupgrade completed successfully. You can check if the fglrx section is missing with:

aticonfig --initial=check

That doesn’t hurt.

Make sure you use the latest version of atiupgrade:

Upgrading ATI driver with atiupgrade

And make sure you have a network connection while booting in runlevel 3. I’ve helped some people who didn’t have any while using the network manager. And I think it is a big problem.

Thanks for your info very useful!!!

Only few other questions:

  1. How do I boot in runlevel 3 (console mode)? Sorry, it is something that I have never done before?

  2. Once I am in console mode, which command I have to compute to check if I have a working internet connection?

Thank you in advance


Press ‘3’ when the grub boot menu appears so that a ‘3’ (no quotes) appears in the grub boot menu options line. See example sketch below:](ImageBam)
[click on image for a larger view]

If you don’t have an internet connection, you won’t be able to add the repo and install the script. So the first zypper command will fail. And even if you got the script before, it wouldn’t be able to download the packages it needs and it will cancel after not founding the kernel sources.

This post Display driver problem? how to restore system? and the following show how a user - without network connection in runlevel 3 - managed to run the script and install the driver under X … but it wasn’t fun. Although since you don’t have another ATI driver already installed, you won’t have the same problem. Let’s just hope you have a network connection!

Thank you for your support so far!!!

Unfortunately after having executed the script in console mode (init 3), I got different error messages telling me that it was not possible, so in my case, the internet connection is not working.

I gave a look to the following post:

Display driver problem? how to restore system?

And I have to say that it is quite messy and risky!!! For this reason, after having read it, I came up with two different solutions ( I hope!!!) that I would like to discuss with you:

  1. I am not connected in runlevel 3 because I am using the networkmanager. You wrote I can try to configure my wireless device to use dhcp but without the network manager and see if it does connect in console mode. Fine, but how I can exclude networkmanager?

  2. You wrote the following:

if you’re not currently using another fglrx driver - you can try to run the script in X after commenting out these two lines (by inserting a “#” at the beginning) in the file /usr/bin/atiupgrade:


ps ax | grep -v grep | grep -q 'X ’ && exec echo “this script cannot be run in X”

ps ax | grep -v grep | grep -q -i 'xorg ’ && exec echo “this script cannot be run in X”

I do not guarantee that it will succeed but it might bring you one step ahead: install the kernel sources, the needed tools and download the ati installer, compile the module and install the driver. aticonfig will fail but you can run it later while rebooting in console mode (you don’t need a network connection for that).

So it should be possible divide the atiupgrade in two scripts:

atiupgrade1 where are included the following sections:

#0) get OS release and ATI model
#1) Make sure kernel sources and compiler are installed
#2) Cancel script if the fglrx module cannot be unloaded
#3) Get the ATI installer

That are all the sections that request a working internet connection.

The atiupgrade2 should be the one must be run in console mode and does not need any working internet connection:

#0) get OS release and ATI model
#4) Create rpm package
#5) Uninstall previoulsy installed fglrx
#6) install fglrx
#7) run aticonfig

Obviously the following part will be in both script:

mach=`uname -m`
kernel=`uname -r`

# use lsb_release to get openSUSE version
which lsb_release >/dev/null 2>&1 || zypper -n in lsb-release

What do you think? Is this a solution that can avoid me any display driver problem like the one in the messy post?



Hmm … I don’t use networkmanager nor do I have wireless devices. But I hope someone could give me a good reason why a Linux system should not be networked while in runlevel 3 (which btw is supposed to mean “Full multiuser with network”). This is beyond my understanding and reminds me of Windows 3.1 before TCP/IP was even implemented.

I guess you would have to configure your wireless device with iwconfig. I don’t think running dhclient on that interface would be sufficient. Out of curiosity … what would happen if you login in X, exit and login in console? You can do that with KDM. Do you lose your network connection as soon as you exit X? I’m asking you because I don’t know.

I think that you really studied this script carefully. Yes it is possible, but not necessary. First you don’t need to split the script. You can run it twice from the beginning. If the ATI installer is found in the current directory, the script won’t try to download it again. So you have to run it the second time from the directory where you stored the ATI installer. If the kernel sources are installed, it won’t try to install them again. So it should not need the network anymore.

Second, you’re not in the same situation as the guy in what you called “the messy post”. You don’t have any other ATI proprietary driver installed, do you? The problem is that the fglrx driver has to be unloaded and to do that, it should not be running. That’s why a script to update the fglrx is not supposed to be run under X.

I think that you really studied this script carefully.

Yes, I study any info in this Forum very well!!! And for this reason:

                      I succeeded in installing the ATI drivers!!!!! 

But I was expecting something better!!! I have to say that after having read your past posts explaining that their performances are not nearly close to the Windows version, I was not thinking to find anything terrific. Notwithstanding, I supposed to find more than simple transparency effects or something like that.

Maybe should I tinker some other configuration files? Or in KDE it’s available a tool where I can improve video performances (better colors, etc)?

I report below the content of the Xorg.conf file:

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0

Section "Module"

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24

Is everything fine or I am missing something?

What I cannot stand is the excessive video brightness that I do not have in Vista!!!



Use the Catalyst Control Center. I don’t know where it is on the menu (it should be somewhere) because I organize menus differently. But if you don’t find it, you can start it with the command:


or if it needs to be run as root with:

amdxdg-su -c amdcccle


I was able to find the ATI driver menu setting, but even I have tried to use different settings, it does not seem that there are improvements:

My settings are:

  1. Tear free setting is enabled
  2. In Anti aliasing ,the setting “override application setting” is unabled.
  3. In Adaptive anti aliasing the setting “override application setting” is unabled.
  4. In Anisotropic Filtering the setting “override application setting” is unabled.
  5. The Mip Map detail setting is set to maximum quality.

In the menu:

System Setting ==>Appearance==>Style==> Fine Tuning tab

There is Graphical Effects Menu the option “Low Display Resolution and very High CPU” is set.

Is my card set correctly or maybe should I do something else? Maybe there is a test application that allow me to see if these settings are good?



I don’t know. The application used to check 3D acceleration is glxgears. But for this kind of settings, I dunno. A couple helpers here know more than me about graphics fine tuning in general and ATI in particular. If they look arround here, they might provide some answers.

Btw I rewrote my script based on your suggestions and on some others’ feedback. That network would not be available in runlevel 3 was something unconceivable for me until I read from several people not being able to use atiupgrade - and canceling the script in X at a early point was the most logical thing to do. Well … I’m speechless. I tend to believe that something is wrong here and that what might be presented as progress is again a regress. Anyway, I organized the steps differently. It should either work in X in one shot if there isn’t any flgrx already installed or do the download in X and install the driver at a later point by exiting X or rebooting in runlevel 3 and simply running atiupgrade again. The detailled explanation can be read in this post: Upgrading ATI driver with atiupgrade.

And there is also “More Settings” where you can tune something at the vertical refresh and enable/disable Catalyst A.I. Do you have this one or was it just added in Catalyst 11.4? Which version do you have? I believe you installed 11.3. What’s the output of

rpm -qa | grep fglrx

It should say 841 rather then 831.

Thanks for your reply

When I compute the command : rpm -qa | grep fglrx, I got


I have installed the 11.3 version. Furthermore when I checked in “More Details”, the settings:

  1. “Wait for vertical refresh” is set to “Quality”
  2. “Enable Catalyst A.I” is active and set to “Advanced”

I cannot see more than this, and it does not seem that there is any performance improvement.

I also tried to google it, unfortunately I did not find any help in other forum posts.



At least you can upgrade to version 11.4 using the latest version of atiupgrade (you’ll have to update it first) and tell me if it works. I did upgrade 3 machines for testing, one in runlevel 3 (I don’t have the network problem that you have), one in X ( step2 in X and step3 in console - that’s what you would have to do) and another in X after rebooting with the radeonhd driver (it’s possible too but it doesn’t bring anything more. I did it only for testing purpose).

I don’t know if/how the latest version has improved. It might in term of hybrid graphics support. But in term of performance, I don’t know.

I was trying, today, to look for info in internet, but unfortunately I found only old posts in other forum with very dated info

I found only a very brief description of this command:


But it looks like a very old fashion tool. I found it in a forum post where they were discussing how to tune the fglrx driver.

Have you ever tried it ?

I do not think version 11.4 will solve the situation (what I do not understand is that all around internet I can find very beautiful linux desktop images, and with a very common ATI card is not possible to get something nice!!!), but anyway I will see in these days.



It is used to set the refresh rates and change the modeline that people might need in /etc/X11/xorg.conf in certain cases and to adjust the size an position of the screen. But it is rather unlikely that you need to do that, since you would notice. When you need to add a modeline, either X doesn’t start at all, your monitor issues a message “out of range” or you get a very low resolution. Is that the case here? What does the following command say:

xdpyinfo | grep dimensions

and if xvidtune is installed (I don’t know if it is by default):

xvidtune -show

Hello, I did fresh install of OpenSUSE 11.4(32bit) today, done update and after that installed ATI Drivers using the first method from this guide SDB:ATI drivers - openSUSE, however Im not sure if that is the latest ATI Driver Screenshot.
If this isnt the latest version of driver, please tell me how to get it. Thanks.
Btw Im using HD 4650 1GB card

Type the following command in a terminal:

rpm -qa | grep fglrx

It should output:** fglrx64_xpic_SUSE114-8.841-1.x86_64** (on a 64bit system).

  • Catalyst 11.4 is 841
  • Catalyst 11.3 is 831
  • and Catalyst 11.2 is 821

This will not work if the method you used names packages differently.

You can also type:


and look under Information -] software. It should say: Catalyst 11.4.

The Catalyst Control Center is not very reliable about version numbers. But it won’t say 11.4 if an older version is installed.

Catalyst 11.4 and openSUSE 11.4 is only a coincidence.

Here is the output: fglrx_xpic_SUSE114-8.831.2-1.i586