Double Letters on console

Hey guys,

I am having serious trouble with my machine (running openSUSE 11.1, all recent updates): Typing “r” on the console (tty1-tty6) gives “rr” and so on - all letters are doubled. The problem occurs only with my USB-keyboard, PS/2 works fine. Here is the odd thing: Under X the USB keyboard works just fine! But all shortcuts are fetched by the system too, so Strg+c not only copies in X but also kills the X server, Strg+Alt+Del reboots the machine etc… VERY annoying!
I have been googleing but found (almost) nothing. Here is a thread I started at (in German only) we could not resolve the problem: LINUX • openSUSE - Tastatur Probleme nach Update: Doppelte Buchstaben
The only thing I found is this: but thats pretty old already (and solved).

What ist wrong here? I did not mess with my configs, it just happened from one day to another. Can you help?

Cheers, Cord

I can’t help with determining the cause of your problems, but perhaps I can help with a solution.

Use the command *showkey *to make certain that each keystroke is creating one and only one key press event and one key release event. If this is not the case, I’d suspect a hardware problem–borrow another keyboard and see if the doubled letter problem persists.

The command for changing the repeat rate and delay in a console is *kbdrate. * The man page is short and to the point. This changes the keyboard repeat settings for one session only and won’t be saved.

Opensuse’s keyboard configuration for tty1 through tty6 is located in the file */etc/sysconfig/keyboard. *The defaults for delay time and repeat rate are empty strings.

# Keyboard delay time in ms (250, 500, 750, 1000)

# Keyboard repeat rate (2.0 - 30.0)


I tried what you wrote, every pressed key results in just one keystroke (pressed and released) so that seems to be just fine. I tried different values for the kbd delay and repeat, that changed nothing.

  • Cord

I apologize, I don’t speak German. Computer translation of the original forum pages is inadequate.

My USB keyboard would briefly lose connection and then reconnect at random intervals and this occurred under both Opensuse and Gentoo. I gave up on the keyboard and replaced it with a PS/2 keyboard. I do not know if a different USB keyboard would have worked.

It does sound like the kernel update caused your problem.

One quick test to truly eliminate hardware would be to boot from a live CD, any distribution.

Have you checked /var/log/Xorg.0.log for errors or warnings? You should also check any lines containing “keyboard” or “Xkb” or “AutoRepeat” for any obvious errors.

I have had hardware problems in the past due to HAL. HAL can misidentify items. In my case, it identified a mouse I didn’t have which stopped it from finding the actual mouse I used. Try

lshal | grep input.product

to check for proper identification of your keyboard.

To see if the proper terminfo is being used, from the tty, both “echo $TERM” and “tset -q” should return “linux”.

Several years ago, some linux distributions had problems with conflicts between a kernel and propietary video drivers that caused keyboard problems. It would surprise me if reinstalling your video driver solved the problem, but it’s possible with the kernel upgrade.

Please tell me if any of this information helps.

After Googling:

Another possible cure is to switch keyboard drivers from “evdev” to “kbd” in xorg.conf.

Can we see your xorg.conf please?


Hey guys,

I was able to solve the problem. Since I have a multiseat configuration, 2 wireless mice and keyboards are connected via USB. Somehow (don’t ask me how) BOTH receivers decided to listen to ONE keyboard. That way on tty I got every letter doubled and in X (since every seat just listens to one USB receiver) I had no problems at all.
I have been running this configuration for quite some time now - but that was nothing I expected. I thought Logitech was smarter than that…

Thank you for your time trying to help me :slight_smile: