Dolphin stopped listing hidden files

Dolphin just stopped showing hidden files in the list in my home folder. They had always been listed before, and they do display in Konquerer and Krusader.

System is openSUSE 11.2 and KDE 4.3.5. I think there were no recent updates that involved Dolphin.

Dolphin is set to split mode. I had my home folder open in both sides, and hidden files were listed. On one side, I went to a sub-folder then back up, and the hidden files were not shown. One the other side, they were still listed. I went to a sub-folder on that other side, back up, and the hidden files were gone there, too.

I have unchecked and checked the “Show Hidden Files” box, and removed and re-installed Dolphin, but the hidden files still will not list. This happens when viewing the home folder on this machine and on other machines on the network.

Any ideas what happened or how to fix it?


Maybe this?
(Folder View Widget properties)

An FYI - Hiding Files and Folders in KDE 4.x and later


crmrhm, I suppose you accidentally toggled the hiding feature - hit Alt + ‘.’ to switch back and forth.

A couple of things: uninstalling and reinstalling things in linux hardly ever works. Only if you destroyed a global config file, or threw away part of a package. What you can do, is remove the program’s config file in your homedir. It somehow holds a setting causing the awkward behaviour. In this case, see that Dolphin is not open, then open a terminal window and do:

mkdir OLDKDEconfigs
mv ~/.kde4/share/config/dolphin* ~/OLDKDEconfigs

Now start Dolphin, see if the problem persists.

gropiuskalle, you are indeed a Wise Penguin, and you suppose correctly. Alt + ‘.’ fixed it. Thank you.

I find this feature also works in Konquerer, but not in Krusader.

Knurpht, thanks for the explanation of why the behavior survived removal and reinstallation of Dolphin.

Where can I learn more about this feature, and others that maybe lurking in the weeds? Is there a description somewhere?


The “feature” I think you’re referring to, is known as shortcuts. In KDE’s Systemsettings you can find all of them under “Shortcuts and Gestures”.

TIP: go in Systemsettings, enter something configurable that you’re looking for, f.e. “key” and see what happens to the icons…some grey out, the others contain options to do with “key”.

I see Alt + . is shown as a keyboard shortcut in the dropdown menu of “View”. I had missed that earlier.

The feature is described in the openSUSE 11.2 November 09, 2009 KDE User Guide, page 22 (file book_kdeuser.pdf), but there appears to be a typo. The guide states:

“3 To make Dolphin also show hidden files, select View > Show Hidden Files or press Alt + +.”

Alt + + did nothing that I could see. Alt + . works.



I am glad I could help you. Happy (un)hiding. :slight_smile:

Hello, I found that searching for hidden files does not work on openSUSE 13.2, Dolphin 14.12.3.
Yes, I pressed Alt + . and didn’t worked.
I tried disabling baloo (desktop search), didn’t work either. Then I added index hidden files=true and index hidden folders=true into baloofilerc, and nothing.

Do you guys know any workarround to fix this?

It can take time for the index to build

Known bug/missing feature I suppose:

I can confirm that searching for hidden files/folders doesn’t work here either (with baloo disabled).

Yes, I pressed Alt + . and didn’t worked.

That’s for listing hidden files/folders (which this thread originally was about), not for searching for them.

Do you guys know any workarround to fix this?

Use kfind (“Find Files/Folders” in the K-Menu).

It’s been days since I turned baloo on, all other files seems to be indexed (like documents, images, videos, etc).

Also, searching for a hidden files should work with baloo turned off right?

Here is a similar post on kde forums:

Yes, I tried kfind and it works. I was aware of bug 269367, thanks.
It’s seems there is something broken with dolphin and baloo (searching a hidden file from krunner does not work).
I hope the KDE team could fix this.

No idea about baloo, but as I said, searching for hidden files/folders (or files in hidden folders) does not work at all even without Baloo.

I hope the KDE team could fix this.

Well, add a comment to the bug report and/or file a new one against Baloo.

Unfortunately this will most likely not be fixed any more for KDE4. There won’t be any new Baloo releases for KDE4, and the KDE4-based dolphin will be unmaintained in August when the first KF5 release will be made.

I did just that :wink:

Well, I guess I’ll have to use KDE5.