Dolphin Missing Panel Options/Features After KDE 4.5 Upgrade

I just noticed that under my panel sub menu, there are no entries after I upgraded to 4.5 from 4.4.4. Also, the embedded terminal option seems to be gone, it now only fires off an external Konsole. :frowning: I really used that feature a lot and it was very handy.

Is this normal?


Couple of questions. Which repo did you use for 4.5 and how did you do the upgrade?

embedded terminal - are you using F4 or the toolbar icon? F4 opens the embedded terminal the toolbar icon opens a Konsole window (at least for me)

panel submenus - have you tried as a diff user? You may need to delete existing dolphin rc files - I think I had the problem but can’t remember what resolved it

I used the following repositories:
Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.3
Index of /repositories/KDE:/Extra/openSUSE_11.3_KDE_Distro_Factory

I used the Switch Repository feature to move from the 4.4.4 to 4.5

I did remove the ~/.kde4/share/config/dolphinrc file but that didn’t change anything, except get rid of the panels I had set as defaults previously, so I moved my original back.

I just tried the F4, if I do that, then the embedded terminal does appear, didn’t remember that. I used to be able to set it in the customize toolbars setting, but now that only appears to have the external konsole launch as an option.


you had the right idea, just didn’t go far enough… your situation happened to me too (and most likely to everyone who upgraded). Rename the following:


then start dolphin and set it up your way, the missing features should be back.

i suspect that other applications really don’t upgrade cleanly, but i haven’t noticed anything else yet. Btw, on my machine, the dolphinpartrc file was not recreated and either i haven’t used the feature requiring it or it is not needed anymore.

PERFECT! Thank you, thank you. That did the trick. :slight_smile: