Dolphin/Konqi only problem - missing window title bar compiz

Strange issue here. When using compiz I lose the window title bar ONLY for konqueror and dolphin! All other apps i tried seem fine. I have tried using compiz-decorator instead of emerald --replace in the compiz windows effect settings and this doesn’t solve it (although it does reliably change the title bar to the kwin theme). I can solve it for one run only if I delete the dolphin config files under my home directory. dolphin then opens unmaximised with a title bar. If I maximize it is okay until next time i start, it then refuses to be taken over by compiz window manager and the top disappears under the plasma panel. I cannot resize the window with alt+button2 which means it’s not just the title bar missing but actually compiz failing to take charge. As mentioned before konqueror displays the same behaviour, but if I launch something like firefox, compiz takes control just fine.

I’d prefer to have compiz enabled for switching between a fullscreen virtualbox and my normal desktop…but seeming as dolphin and konqueror are THE two main apps it’s not really an option right now. by the way, i’m running 11.0 with the kde4:factory. I have another box running a very similar configuration and don’t seem to have this issue. Not sure if it’s a bug in compiz,kde4 or opensuse!

Anyone else seen this behaviour??

I think I have the same problem with dolphin and konqueror.
But there is a work around, simply right click the applet in the task bar select advanced and uncheck “FULLSCREEN”.

So the window decorations are there the apps are starting in fullscreen mode.

What I (and maybe you) need is info on how to change the startup behavior for these apps from starting fullscreen to regular Maximized.

I had that issue with KDE3 some time ago. It turned out to be nVidia Drivers were not installed properly. I had downloaded the .run file from nVidia and installed it manually instead of using YAST and I had messed something up. Maybe it helps to check the drivers (even thou I don’t really know much about KDE4).

I’d never thought to check the fullscreen option…definitely a bug though if it puts itself into fullscreen without being asked!
I have an onboard intel video so i doubt it’s a video driver issue…it would be very strange if it was seeming as it’s application specific. I know dolphin uses some of the konqueror lib files so I figure it’s probably actually a konqeuror issue that shows up in both.
I will try to fullscreen ting when I get back to work!


Take a look to this blog:

CyberOrg » Compiz Fusion Git snapshot for openSUSE 11.1

That was the only way I could fix everything … Now I’m using emerald with no single issue.

Take a look to this post (almost at the end) and check the steps I took to fix it.

Quitting KDE4 applications on GNOME desktop kills Compiz - openSUSE Forums

Good luck


NOTE: Take in mind that this is for developers …

thanks I’ll definitely be checking this out

I like solphonic am running Suse 11.0 with KDE 4.1 Factory and I am not ready to upgrade to 11.1 just yet. Only certain apps start fullscreen not all of them. There must be a way to set how an app starts and save it.


I don’t understand this… Your using OS 11 Factory? do you mean OS 11.2 Pre Alpha? … Sorry but sometimes I’ get so mixed up with this.


run the command in bash:

gtk-window-decorator --replace &

To get rid of the always maximized when opened, open up the CompizConfig Settings Manager (CCSM) and go to the Utility Section. Find the plugin Workarounds then click into it. Uncheck Legacy Fullscreen Support.

Take Care,