Dolphin crashing on plasma 5

Everytime I try to use “right click” to do something like creating a folder or so, dolphin file manager crashes right after displaying the right click context menu. I’m using Leap 42.1 x64 and I haven’t found a work around or something (rebooting delays the crash only).

Upgrade/fresh install? Using old desktop config from previous version?

Try a different user.

Only workaround is disabling link to activities in dolphin preferences->services .

There are other workarounds that should fix the issue:

  • Delete ~/.local/share/kactivitymanagerd/ outside of Plasma5 (without dolphin running)
  • Switch to a different widget style (oxygen e.g.), the crash only happens with breeze. It should even be fixed if you then switch back to breeze…

Btw, the crash only happens when opening the “Activities…” sub menu.

Fresh install, not upgrade. Desktop pc from last year.
I’m turning off the activities service on dolphin and see if that helps like you guys said, thanks lads!

I have tried your suggestion. Outside KDE i have deleted kactivitimanagerd and also switched widget style to fusion, but to no effect. Still crash on Activities.
This is what terminal says:

The desktop entry file "/home/jana/Downloads/.directory" has Type= "Application" but no Exec line
QThread: Destroyed while thread is still running
Segmentation fault

It has been 2 days and I haven’t experienced any issues with dolphin, removing the activities thingy solved it for me. Should I mark this thread as solved or closed? :slight_smile:

Probably want to reort it on bugzill

Same user/password as here

Better report it upstream at if you want to report it.

KDE develops dolphin and kactivities, not openSUSE.