Does the OS know what voltage the SBC gets?

I am sorry but I have to return to this subject and remove the tick in the “solved” box.

According to Jack of the Radxa team:

This is implemented by the ADC monitoring the input voltage on the ROCK 5B.

Further info is supplied by the user amazingfate:

Sysfs is provided by kernel driver, no userspace program is necessary.

So it might be possible to see the usb-c input voltage after all. Could it be that the placement of that information in the /sys file system has changed in later kernels, such as the 6.8 I have?

Apparently I’m on an ACPI system.

From the Radxa forum – amazingfate:

You are running an acpi system, so there should be a lot of missing hardwares on board. Mainline kernel has &saradc in devicetree since v6.5:

Could someone please help me understand what that means?

@hukka then I suspect you need to find out what is required (if like the RPi3) options in a /boot/efi/extraconfig.txt. Best to head over to the openSUSE ARM Mailing List for that…

Wow. That is a pretty complicated thing to do…

@hukka not really, they likely have someone there running the same hardware as you and can advise…

I’m assuming it’s this

I’ve seen that wiki page before but only glanced over it. There’s no product called Rock Pi 5.

Radxa produces the Rock 5A that is sized as a Raspberry Pi 5 and The Rock 5B (the one I have) at a pico-ITX size. Recently they have announced three more additions to the Rock 5 series; the Rock 5C and Rock 5C lite, both with a Raspberry Pi 5 size, and the Rock 5 ITX in a mini-ITX size.

Having just one wiki page for the Rock 5 series is a bit problematic as the hardware differs between the models. One example is that the Rock 5C Lite uses a RK3582 SoC, while the others use some variant of the 3588 chip.

So the mailing-lists offer something like a haystack situation. However, I did find the post that helped me get started. Sadly that user hasn’t published anything since.

But homework is homework, after all, so back to the haystack.

@hukka Um, no, not a haystack, that is were the openSUSE ARM developers hangout that bring the images to life that you installed, or create a bug report.

It’s not just one page, see here for the boards:

The problem isn’t the haystack itself, but rather that I simply don’t know what I’m looking for.

I’ll try to explain better.

If the mailing-list references the HCL: Rock Pi 5 page then that leads to a dead end.

The link on that page leads to where the Rock Pi 5 product can’t be found.
The Radxa site is now actually located at
The Radxa site has a products page but there’s no product called Rock Pi 5

The specifications on the HCL page instead hint at the Rock 5A.

But there’s also a SBC called Rock 5B which is the one I have.
…and the new Rock 5C that soon will be followed by the cut-corner Rock 5C Lite.
Later this year Radxa will add a mini-ITX motherboard too, the Rock 5 ITX.

They’re all different and need separate HCL pages.

On top of that I don’t know enough to formulate what I am searching for. Yes, the input voltage is what I want to know, but how does the computer measure it and what process makes that measurement available? The suggestions I get from the Radxa Forum (from their Debian viewpoint) fail because the path to the information that I want doesn’t exist on my machine running Tumbleweed.

The latest comments from the Radxa Forum points at ACPI being the reason to why that folder inside of /sys doesn’t exist here. So I carry on, regrettably irritating people in the process, but slooowly getting there. …I hope.

And it all started with an innocent quest for the input voltage of the USB-c socket. Little did I know… :upside_down_face:

1 Like

The Radxa forum user amazingfate suggests:

You can load devicetree from grub with command like:
devicetree /boot/dtb/rk3588-rock-5b.dtb.


Would it be possible to add a file like that to my system? Would it get me the devices I need?

@hukka if you post on the Mailing List and ask the ARM developers to look at adding or ask if possible, they will likely guide you…

“Then”, said the wanderer worriedly looking into the dark forest, “then that is the path I must travel. Wish me luck!”

1 Like

@hukka so the device tree on my RPi3 is /boot/efi which it where I use extraconfig.txt to add overlay files for the gps and RTC…

1 Like

Picking up some light reading…

Tumbleweed on the Raspberry Pi handles most of the hardware by itself and only uses extraconfig.txt for a few exceptions, right?

@hukka yes, for external hardware. In this case I’m using the GPS pps signal for chrony to use on a GPIO input and also telling it I have an RTC module for it to use to keep the hardware time current on shutdown/boot.

Yours is an actual module, how it gets activated on that hardware I have no idea…

So… I’m actually relieved that tumbleweed does most of the work by itself. Now I just have to figure out what makes the work and how… I have a headache. :face_with_head_bandage:

Possibly you can get that info from USB subsystem.

Power Requirements

USB Type-C™ PD Version 2.0 with 9V/2A, 12V/2A, 15V/2A and 20V/2A

Power adapter with fixed voltage in 5.2V to 20V range on the USB Type-C port

5V Power applied to the GPIO PIN 2 & 4

ILL board needs at least 5.2V 2A.

The various subsystem voltages like CPU, GPU, etc. are shown by sensors output as mentioned by @malcolmlewis if available. On my machine it shows:

Adapter: PCI adapter
Tctl:         +49.9°C  

Adapter: PCI adapter
vddgfx:        1.12 V  
vddnb:       674.00 mV 
edge:         +45.0°C  
PPT:           9.00 W  

Adapter: ACPI interface
in0:           7.98 V  

Adapter: PCI adapter
Composite:    +28.9°C  (low  = -273.1°C, high = +80.8°C)
                       (crit = +86.8°C)
Sensor 1:     +28.9°C  (low  = -273.1°C, high = +65261.8°C)

For measuring the voltage/current delivered by the PD supply, you could use a USB power meter like this one:

If i run sensors as root I only get the data about the nvme device. I get the composite and two sensor readings. Nothing else.

I expected something like the sensors command to display the input voltage of the usb-c connector, but so far I only get a subset of the sensor data, a subset that doesn’t contain the information I want.

Using an external volt meter for usb-c is a possibility, but I wanted to know if the OS itself knows. The answer is yes but I don’t know how to see that information, at least not yet.

1 Like