DNS Server won't start automatically on system bootup - Tumbleweed 06112016


I just reinstalled a fresh copy openSUSE Tumbleweed 06112016 on my server and have run into a minor, but annoying issue. The DNS server startup on system boot setting won’t stay checked, so every time I reboot the server I have to manually start DNS.

I also tried setting Named in System Services to Enable but that constantly flips back to Disabled.

Any ideas why its doing this?

If setting up a DNS server on openSUSE is new to you,

You will probably want to install the YAST DNS Server applet, the following assumes you’re installing BIND as your DNS (there are others including dnsmasq)

zypper in bind yast2-dns-server

After the above, you will find a DNS Server applet in YAST > Network Services

The applet can walk you through configuring a zone for an Apex Domain and on the last form provides radio buttons for configuring your DNS server to start on boot or only manually.

Also, FYI you can run the following in a root console to configure BIND to start on boot.

systemctl enable named.service

If it’s not already running, you may want to manually start the service immediately instead of re-booting

systemctl start named.service


Thanks for the reply!

I forgot to mention that I’m using YaST to configure DNS (and YaST for System Services) and that is what is failing me.

I’ll try some of the commands you specified. Its really weird that the start on boot isn’t sticking…