DLNA client

Over the years have tried a few times to get a DLNA client working on opensuse, but still no success…
Have a fairly standard Leap 42.2 x64 install, using Pacman repos, but have never successfully got a dlna client working.
VLC>playlist>Local Network>Universal Plug’n’play (generally the recommended solution) - nothing. Comes back with a blank playlist window - I have several DLNA sources on the network - Plex, a router, a PVR, and at various times possibly an android device.
Yes, I know there are a few DLNA client command line apps that probably work, but, seriously, this is one of the things that a lot of ‘newbies’ will want to do, and can be done easily on just about any other operating system, but not on linux/opensuse particularly.
Anyone have an easy, graphical way of doing this?
(BTW, I DO love opensuse… :slight_smile: )

Wikipedia suggests these



Almost to the point where I am believing this is impossible…
Have installed several apps that are supposed to work as DLNA clients (VLC, RhythmBox + Totem with grilo), and all I manage to do is get an empty window where my DLNA files are supposed to be… No errors/messages at all. Doesn’t appear to even be any attempt to search the network/whatever.
Is there a “lower level” library/utility that just isn’t there in opensuse?

Just for testing I installed Totem with “grilo-plugin-dleyna”.
Works for me.


Ype, still not working. Have booted into Gnome just to see if it is a gnome/KDE thing, but still no go, even after reinstalling both Totem and the “grilo-plugin-dleyna”…
Should “grilo-plugin-dleyna” be available in the plugins dialogue? 'cause mine isn’t…
All I see in Channels is Rai.tv

Any help appreciated.

Perhaps your server software and devices aren’t actually DLNA compliant, or haven’t been configured properly.

The Wikipedia link I posted also contains a section of Server software, and Plex isn’t listed.
Recommend you try installing something on the list and test again.


Thanks for the comment, but Plex is on the list under cross-platform. Am also confident that the others are compliant enough to be considered as well, as they are fine for all other devices I have ever connected from, including Windows/Android/Apple/Frontier Silicon based devices, etc.
Would like to have the knowledge (or the resources), to be able to trouble shoot myself, but unfortunately not…

Works here, however VLC 2.2* had some weird issues with UPNP on hardware with multiple network connections.

Could you try vlc-beta and DROP your SUSE firewall when you try it.

Note, there’s still something odd about libupnp and vlc, it might take a few moments for the DLNA server to be found so don’t jump out of the window instantly.

Success in some form…
Believe the main issue seemed to be networking, but I did uninstall VLC and installed the beta, as well (yep, I know, don’t make more than 1 change at a time…)
I am using wireless, and had seen something about disabling IPV6, so thought I would do that. Went into networking, and noticed I could only see 1 of my my wifi access points (I have 3 - don’t ask! And, yes, I am using WiFi, as the house is just too difficult to wire) no matter what I did. So ended up deleting my network configuration, and redoing from scratch. As it turned out, after this I ran Totem and could see (and play from) one of my servers.
On reinstalling VLC, could then see two sources on the network, so believe my main issues have been overcome.

Thanks for the suggestions/ideas! Don’t need to jump out of any windows, now!! :slight_smile:

I’ve just run into the same issues. I run minidlna on a raspbian-based Pi, which streams music and movies in the house. This works perfectly with android tablets and slickpnp, but it’s been a job getting it working reliably on the OpenSUSE laptops. I’ve not been able to get vlc working with upnp streaming at all (it works well under Android though and has a reasonably workable interface.)

The upshot is that rhythmbox works for audio, and totem works for video. Both have dreadful interfaces, but they do work.
It is necessary to install grilo-plugins as well as grilo-plugins-dlayna, and enable grilo in rhtymbox preferences. And finally - the only way it would work - is by disabling SuSEFirewall2. What is more, you have to disable the firewall and then start rhythmbox or totem.

I *think *the following works. Under Yast, firewall, add a custom rule. The source network should be your local network, and the source port, 1900. The protocol is UDP, and you can leave the destination port blank.

Really, it should be easier than this. Hope this helps.

Sorry about this - belay the bit about opening port 1900 UDP - I should have tested it a little more before posting. It doesn’t work reliably. The only way I have so far is to switch off SuSEfirewall2…

Recommend you configure the iptables configuration described at this link