Distrobox-export --app on opensuse AEON

Installed freeoffice for openSuse (Service zu FreeOffice: FreeOffice für Linux installieren) in my Tumbleweed-distrobox on opensuse AEON. This installed textmaker24free, planmaker24free and presentations24free. Then I tried “distrobox-export --app textmaker24free” and end up with:
Error: cannot find any desktop files.
Error: trying to export a non-installed appliction.
First error: the starter wasn’t found I guess
Second error: I’m wondering cause “textmaker24free + enter” makes the programm run in my tumblweed-distrobox.
Any ideas how I can make ‘distrobox-export --app textmaker24free’ work, i. e. put the textmaker-starter to my gnome desktop?

Try shorten it like chrome PWA or davinci using distrobox-export --app chrome exports all installed chrome stuff and PWA ones it is picky on the name

It could be named as freeoffice

Tried this with several versions of “freeoffice” without success and end up with a look at real names in usr/bin.

At a guess, look for files named with a .desktop extension and try using that name with the distrobox-export command.

If you don’t have a .desktop file, then use --bin instead and point to the binary. See man distrobox-export for more info.

I did so but haven’t found .desktop for freeoffice and I guess I need the correct name for --app. Using --bin means open terminal to start the programm. In this case a start directly from distrobox lasts no longer.

I would look at the man page, it explains what you need to do. If a desktop file doesn’t exist, you can create one.

It’s a third party RPM coming from a non openSUSE repository, that we have no real idea how it’s put together. It’s entirely possible it’s not providing a .desktop file.

/usr/share/applications is the most common place for RPM’s to dump their .desktop files, I’d try looking there.

1 Like

After installling freeoffice inside your distrobox you can list the
installed .desktop files, if any with:

$ rpm -ql softmaker-freeoffice-2024 | grep \.desktop$

Of these six files, the files ending with free24.desktop are the files
you are looking for, since they contain [Desktop entry].

The easiest way to use distrobox-export --app with these files seems
to be a symlink to e.g. /usr/local/share/applications, which appears
to be empty in fresh distroboxes for me. Symlink all three files likes this:
sudo ln -s /usr/share/freeoffice2024/mime/*free24.desktop /usr/local/share/applications/

You can confirm in the distrobox-export script file upstream which
directories are considered for export of an app:

Then all that is left to do is export the three apps:

for appname in presentations24free textmaker24free planmaker24free; do distrobox-export --app appname; done

Then you should be done.
Optionally, you could report a bug upstream (freeoffice) and discuss with them if
another location for their .desktop files would be more sensible.

1 Like

Wow – at least I can understand it. But the symlink target has no application folder.

You can create the folder or use one of the other already existing folders which get searched.
I put them in /usr/local/share/applications so it’s separated from the automatically installed stuff.

A more throrough walkthrough:
Create the distrobox

distrobox create -n freeoffice

Enter it:

distrobox enter freeoffice

Inside the distrobox:

sudo zypper addrepo -f https://shop.softmaker.com/repo/rpm SoftMaker
sudo zypper --gpg-auto-import-keys ref
sudo zypper install -y softmaker-freeoffice-2024
sudo mkdir /usr/local/share/applications
sudo ln -s /usr/share/freeoffice2024/mime/*free24.desktop /usr/local/share/applications
sudo chown -R nobody:nobody /usr/local/share/applications
distrobox-export --app planmaker24free
distrobox-export --app presentations24free
distrobox-export --app textmaker24free
1 Like

Thank you verry much for these ready to use solutions - helped me a lot. Comprehensible and great fun to reproduce. Your second solution is quiet elegant.

No worries, glad you had fun :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.