DisplayCal don´t start under KDE OpenSuse Leap 15.0 and 15.1


The newest DisplayCal doesn’t start under Leap 15.0 (which I use) and 15.1 (which live I have tested). It’s supposed, that the Python 2.7 Install is broken; I have tried to reinstall libpython2_7 and the same 32-bit, but that didn’t help either.

Please see the Link


for more information.

Thanks in advance,

I tried installing “displaycal-” on a Leap 15.1 system.

It installs without a problem.

I started it from the KDE menu. It seemed to run without problems.

However – it did want me to upgrade to a later version (3.8.2, I think). I declined, because I prefer to install from the standard repos rather than over the web. It also wanted to upgrade another component (I also declined).

I’m not familiar with the software, so I’m not sure whether it works properly. But it starts up without problems, other than the need to skip the update offers. And it looks as if it would work.

Maybe if I had upgraded to that suggested version, it might have failed. I’m not about to test that. I’m inclined to think it a misfeature, that the software even asks me to upgrade outside of the standard openSUSE repos.

In your case there’s no question about that. The error you were getting:

import xml.parsers.expat
ImportError: No module named xml.parsers.expat

The XML module is part of the Python standard library.

Note that I cannot reproduce the problem (Tumbleweed).

I have attached a Konsole output, maybe it will help to debug this problem.

A newbee question: How can I repair my broken Python installation? Which files do I need to replace/update? I have tried python, python-base, python-xml already.

The next interesting thing is that I was able to successfully launch 3.8.2 in other Leap 15.0 install/other computer, where everything works as expected.

Thanks in advance,


~> displaycal
XDG: [Errno 2] No translation file found for domain: xdg-user-dirs
displaycal 2019-06-09T15:21:39.523195Z
Python 2.7.14 (default, Oct 12 2017, 15:50:02) [GCC]
ImportError: No module named faulthandler
ImportError: /usr/lib64/libgio-2.0.so.0: undefined symbol: g_utf8_validate_len

Traceback (most recent call last):
File “/usr/bin/displaycal”, line 6, in <module>
File “/usr/lib64/python2.7/site-packages/DisplayCAL/main.py”, line 92, in main
from wxaddons import wx
File “/usr/lib64/python2.7/site-packages/DisplayCAL/wxaddons.py”, line 10, in <module>
from wxfixes import wx, GenButton, PlateButton, get_dialogs
File “/usr/lib64/python2.7/site-packages/DisplayCAL/wxfixes.py”, line 24, in <module>
import wx
File “/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/init.py”, line 45, in <module>
from wx._core import *
File “/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py”, line 4, in <module>
import core
ImportError: /usr/lib64/libgio-2.0.so.0: undefined symbol: g_utf8_validate_len
/usr/lib64/python2.7/site-packages/wx-3.0-gtk2/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
Segmentation fault (core dumped)

That’s a different error now. Seems there are other things awry on your system. Maybe check your LD_LIBRARY_PATH for conflicting versions of glib.

The first error was in Leap 15.1 live, the second, that in recent post, was from my Leap 15.0.

Newbee question: how can I do that? I have issued the commando “printenv”, but there was no LD… Also, it seems, that today was the update for glib2, that didn’t help.

Thanks in advance,


But to be honest, since you already have a working 15.0 install, it’ll probably be easiest to just do a clean re-install of the other system(s).

That´s why I’ve taken live Leap 15.1 for experiments… Will wait for the next image, the image from 04.06 was the last available.

BTW, the echo command returned nothing, just the empty line.