Display standby: where do I disable it?

I have disabled all energy saving settings for my display in system settings (see screenshot) but my screen still keeps blanking after a few minutes. Where can I disable this additional setting? I cannot seem to find anything, energy saving settings are also all disabled in BIOS-setup, it’s not a BIOS issue either. Talking about openSUSE 11 with KDE 4.0.4 here.


  • mj42

this is nagging me since 10.x, the only way I found is to start sax2 and disable DPMS for the display.


Thank you! That did indeed solve the problem. I can even use the energy saving settings now because they actually do work once DPMS is disabled :slight_smile:

mj42 wrote:

> Thank you! That did indeed solve the problem, and now I can even use the
> energy saving settings because they actually do work now :slight_smile:

Xwindows defaults to blanking the screen after 600 seconds (10 minutes)

Can be changed with the xset command:

set no blanking ever

xset s off

set blanking after 3 minutes

xset s 180

xset also handles DPMS settings

turn dpms off entirely

xset -dpms

enable dpms with Xserver defaults

xset +dpms

set dpms for standby after 30 minutes, suspend after 45 minutes and off

after 60 minutes
xset dpms 1800 2700 3600

remember, ALL times are from ‘zero’, and must be ascending if specified.

standby <= suspend <= off

the xset man page has more information, and there are many more options to
tweak. (‘xset q’ is very useful)

L R Nix

In case you have a text mode installation you can add the following to /etc/init.d/boot.local:

setterm -blank 0
setterm -powersave off
setterm -powerdown 0

More info in the man pages for setterm.