Display manager starts Xorg DEs just fine, but crashes when using Wayland (logs provided)

(journalctl log of a boot is here: https://0x0.st/HoyP.txt)

On Tumbleweed, I’m using GDM as my display manager. It is enabled at startup, and it displays the login screen just fine. However, if I select “Plasma (Wayland)” as the Desktop Environment and login, there is a completely blank white screen with only a mouse cursor on it. However, if I select “Plasma (X11)” and log in, everything starts fine.

I checked that the GDM daemon and the non-root user are in the video group. I tried logging in as root to see if it was a permissions issue with the user, and the same thing happened. This is some kind of Wayland specific issue, and it’s not obvious to me what it is. The log I posted above is of a boot in which I did the following:

  • Logged in as an ordinary user on ‘Plasma (X11)’

  • Briefly opened a terminal and typed a command

  • Logged out

  • Logged in as the same user using ‘Plasma (Wayland)’

As expected, something crashed. If anyone could me sort out what’s going on in the log, I would appreciate it.

Please post your journal to https://paste.opensuse.org/ as your links looks fishy…

Posted:
https://paste.opensuse.org/pastes/9be4bb36fdca

Sorry for the fishy-looking link.

Some thoughts…

If you create a new user (via Plasma X11), can you get a working Plasma (Wayland) session logging in as the new user?

Eliminate the display manager as a culprit by trying SDDM. Same behaviour? With SDDM at least, Wayland sessions are logged to ~/.local/share/sddm/wayland-session.log (but I’m not sure where GDM does this).

I disabled GDM, enabled SDDM, created a new user, rebooted and tried to log in. The same problem: X11 sessions start, Wayland sessions crash.

There’s only one line in my /home/user/.local/sddm/wayland-session.log file:

/tmp/xsess-env-KZUHzs: line 60: PROFILEREAD: readonly variable

I went to /tmp/xsess-env-KZUHzs and checked line 60. The line is export PROFILEREAD="true" (which is not very helpful). Any idea where I should look?

You may need to explore further debugging options…
https://community.kde.org/KWin/Debugging

Ultimately a bug report will be required.

It’s no secret that Wayland is still in development, and keyed to GDM/Gnome. Wayland is simply not mature enough for every Plasma user. OTOH, SDDM was designed by KDE devs for KDE, so you should be able to count on SDDM for making Plasma run, if compatible with your environment, whether or not Wayland is part of it.

…and how does any of this help the OP?

1 Like

Suggests time spent other than on filing a Wayland bug report (assuming one or more don’t already exist covering OP’s issue) or using Xorg/X11 instead of Wayland for Plasma is a waste of time.

Posting non-constructive comments in a technical help thread is a waste of time and effort.

This snippet from your log may be of interest here…

Mar 27 13:19:12 localhost kwin_wayland[4521]: kwin_core: Parse error in tiles configuration for monitor "69e41f1c-42c4-5d73-a195-d7c32a4cfa53" : "illegal value" Creating default setup
Mar 27 13:19:12 localhost kwin_wayland[4521]: kwin_xkbcommon: XKB: inet:323:58: unrecognized keysym "XF86EmojiPicker"
Mar 27 13:19:12 localhost kwin_wayland[4521]: kwin_xkbcommon: XKB: inet:324:58: unrecognized keysym "XF86Dictate"
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4660]: (WW) Option "-listen" for file descriptors is deprecated
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4660]: Please use "-listenfd" instead.
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4660]: (WW) Option "-listen" for file descriptors is deprecated
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4660]: Please use "-listenfd" instead.
Mar 27 13:19:12 localhost kwin_wayland[4521]: js: Not found the '__dde__' object
Mar 27 13:19:12 localhost kcminit_startup[4527]: Initializing  "/usr/lib64/qt5/plugins/plasma/kcms/systemsettings/kcm_fonts.so"
Mar 27 13:19:12 localhost dbus-daemon[2567]: [session uid=1001 pid=2567] Successfully activated service 'org.kde.KSplash'
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4691]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4691]: > Warning:          Unsupported maximum keycode 708, clipping.
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4691]: >                   X11 cannot support keycodes above 255.
Mar 27 13:19:12 localhost kwin_wayland_wrapper[4691]: Errors from xkbcomp are not fatal to the X server
Mar 27 13:19:12 localhost kcminit_startup[4527]: Initializing  "/usr/lib64/qt5/plugins/plasma/kcms/systemsettings/kcm_style.so"
Mar 27 13:19:12 localhost kcminit_startup[4527]: Initializing  "/usr/lib64/qt5/plugins/plasma/kcms/systemsettings/kcm_mouse.so"
Mar 27 13:19:12 localhost systemd[2451]: Started KDE Config Module Initialization.
Mar 27 13:19:12 localhost systemd[2451]: Starting KDE Session Management Server...
Mar 27 13:19:12 localhost systemd[2451]: Started Unlock kwallet from pam credentials.
Mar 27 13:19:12 localhost systemd[2451]: Starting KDE Daemon...
Mar 27 13:19:13 localhost systemd[2451]: Started dde-calendar date service.
Mar 27 13:19:13 localhost dbus-daemon[2567]: [session uid=1001 pid=2567] Activating service name='com.deepin.dataserver.Calendar' requested by ':1.94' (uid=1001 pid=4711 comm="dbus-send --session --print-reply --dest=com.deepi")
Mar 27 13:19:13 localhost com.deepin.dataserver.Calendar[4713]: 2023-03-27, 13:19:13.010 [Debug  ] [  ] write log to "/home/user/.cache/deepin/dde-calendar-service/dde-calendar-service.log"
Mar 27 13:19:13 localhost dbus-daemon[2567]: [session uid=1001 pid=2567] Successfully activated service 'com.deepin.dataserver.Calendar'
Mar 27 13:19:13 localhost com.deepin.dataserver.Calendar[4713]: 2023-03-27, 13:19:13.011 [Debug  ] [  ] "" "" "en_US.UTF-8"
Mar 27 13:19:13 localhost com.deepin.dataserver.Calendar[4713]: 2023-03-27, 13:19:13.011 [Debug  ] [  ] sessionBus.registerService success "/home/user/.cache/deepin/dde-calendar-service/dde-calendar-service.log"
Mar 27 13:19:13 localhost bash[4711]: method return time=1679937553.012100 sender=:1.95 -> destination=:1.94 serial=7 reply_serial=2
Mar 27 13:19:13 localhost ksmserver[4695]: Qt: Session management error: networkIdsList argument is NULL
Mar 27 13:19:13 localhost systemd[2451]: Started KDE Daemon.
Mar 27 13:19:13 localhost systemd[2451]: Starting KDE Configuration Module Initialization (Phase 1)...
Mar 27 13:19:13 localhost kcminit_startup[4527]: Initializing  "/usr/lib64/qt5/plugins/plasma/kcms/systemsettings/kcm_kgamma.so"
Mar 27 13:19:13 localhost kded5[4748]: xsettingsd: Loaded 0 settings from /home/user/.config/xsettingsd/xsettingsd.conf
Mar 27 13:19:13 localhost kded5[4752]: xsettingsd: Loaded 14 settings from /home/user/.config/xsettingsd/xsettingsd.conf
Mar 27 13:19:13 localhost systemd[2451]: Started KDE Session Management Server.
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Loaded 0 settings from /home/user/.config/xsettingsd/xsettingsd.conf
Mar 27 13:19:13 localhost systemd[2451]: Starting KDE Plasma Workspace...
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Created window 0x800001 on screen 0 with timestamp 75071
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Selection _XSETTINGS_S0 is owned by 0x0
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Took ownership of selection _XSETTINGS_S0
Mar 27 13:19:13 localhost kcminit_startup[4527]: Initializing  "/usr/lib64/qt5/plugins/plasma/kcms/systemsettings/kcm_touchpad.so"
Mar 27 13:19:13 localhost systemd[2451]: Finished KDE Configuration Module Initialization (Phase 1).
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Reloading configuration
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Loaded 14 settings from /home/user/.config/xsettingsd/xsettingsd.conf
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Reloading configuration
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Loaded 14 settings from /home/user/.config/xsettingsd/xsettingsd.conf
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Reloading configuration
Mar 27 13:19:13 localhost kded5[4756]: xsettingsd: Loaded 14 settings from /home/user/.config/xsettingsd/xsettingsd.conf
Mar 27 13:19:13 localhost dbus-daemon[2567]: [session uid=1001 pid=2567] Activating via systemd: service name='org.kde.ActivityManager' unit='plasma-kactivitymanagerd.service' requested by ':1.98' (uid=1001 pid=4757 comm="/usr/bin/plasmashell --no-respawn")
Mar 27 13:19:13 localhost systemd[2451]: Starting KActivityManager Activity manager Service...
Mar 27 13:19:13 localhost systemd[2451]: Started KDE Plasma Workspace.
Mar 27 13:19:13 localhost systemd[2451]: Reached target KDE Plasma Workspace Core.
Mar 27 13:19:13 localhost systemd[2451]: Started Proxies GTK DBus menus to a Plasma readable format.
Mar 27 13:19:13 localhost systemd[2451]: Starting KDE PolicyKit Authentication Agent...
Mar 27 13:19:13 localhost systemd[2451]: Starting Powerdevil...
Mar 27 13:19:13 localhost systemd[2451]: Started Handle legacy xembed system tray icons.
Mar 27 13:19:13 localhost plasmashell[4757]: Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
Mar 27 13:19:13 localhost plasmashell[4757]: If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.
Mar 27 13:19:13 localhost dbus-daemon[2567]: [session uid=1001 pid=2567] Successfully activated service 'org.kde.ActivityManager'
Mar 27 13:19:13 localhost plasmashell[4757]: Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.
Mar 27 13:19:13 localhost plasmashell[4757]: If this Plasma has been installed into a custom prefix, verify that its D-Bus services dir is known to the system for the daemon to be activatable.

@jpeg Something to try: Add “amdgpu.sg_display=0” to your boot parameters and see if that helps with this issue.

References:

@deano_ferrari I passed the parameter to grub on the splash screen and, unfortunately, nothing changed. The SDDM log file is the same, as is /tmp/xsess-env-KZUHzs.

I’ll live with X for the moment. I’ll look around KDE to see if there’s a bug report, and may file one myself if not. I will update this thread for those who have similar problems in the future if I ever figure this out. This is a relatively new install, so I may just reinstall and see if that fixes anything.

Update: Reinstalled Tumbleweed. Had the same problem: X works, Wayland doesn’t. Upon rebooting and passing the amdgpu.sg_display=0 to the kernel and to my surprise, Plasma on Wayland actually loaded.

I assume that messing with the display on the old installed probably caused more problems.

Anyway, thanks for the help!

Thanks for the update. Back away slowly now. :slight_smile:

I’m tagging you and reopening the thread because this feels like something that should be reported, and I’m not sure who to report it to. The error came up again after the new install, and I was trying to figure out what was wrong.

Eventually I figured out what the problem was: I changed the default login shell from bash to fish. When I changed it back to bash, the Wayland environments worked fine. When I changed it back to fish and rebooted, both SDDM + GDM gave the same errors and wouldn’t load the Wayland DEs (but they would load the X11 DEs).

I’m probably going to try messing around with more shells. But who do I even report this to?

Just needed to create an account to thank you for this finding. I had the exact same issue with fish. Changing to bash suddenly plasma-wayland started to work.

Was this reported somewhere? Otherwise I could open a ticket to kde-plasma, which I guess is the right place?

When you are going to report this upstream then please leave out the word “default”. Each user has just one “login shell”. The only place where one could speak about a “default login shell” is when the system manager creates a new user and having the choice, often will give the user what he sees as default.

Hi all. I couldn’t find if the bug was properly reported or not, but I have been able to reproduce it on my Tumbleweed install. Same issue; after selecting Plasma Wayland in SDDM, it put me on a black screen. Going to the next TTY (CTRL-ALT-F3) would leave it at a black screen, but when switched back to the default display TTY I could see the mouse moving around and nothing else. From there, you can switch back to a different TTY and the normal vTTY login prompt will be displayed, and you can just log in and run startplasma-wayland, and the session will properly start on that TTY. This issue does not occur when starting Plasma X11.
It’s important to note that this machine has 2 user accounts, both of them with the user shell set to fish with chsh. On the first and initially created account, this issue does not happen, and SDDM loads Plasma Wayland no problem.
The solution of changing the login shell from fish to bash fixed the issue.

Operating System: openSUSE Tumbleweed 20230911
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Kernel Version: 6.5.2-1-default (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 480 Graphics
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: X470 AORUS GAMING 5 WIFI