Display geometry function not working?


11.1 RC1. (hey this is new, I can edit my OP now :))

In Configure Desktop/Window Behavior_Tab=Moving, there is an option that says “Display window geometry when moving and resizing”.

Can anyone try it and tell me the result? I am trying it and it does not work at all. Nothing displays. That’s a function I use often when I use compiz-fusion (I can’t make it work yet due to package versions differences) and I see it’s available with the simple KDE4 effects. But it does not work for me.

I tried some window-specific effects and these work, but that window behavior (display geometry) does not seem to.

Before I log a bug on that for 11.2.

Have you loaded the OEM driver for your video card?
If so, edit /etc/x11/xorg.conf to read

Section "Extensions"
  Option       "Composite" "on"

should work;)

Actually I forgot to mention, I use the nvidia 177.80 or 177.82 driver, the latest or second latest.

I mean all the 3D effects work, except I can’t get this one to work.

I do have composite enabled. I also have AWN running and it requires composite to be enabled, so I assume here that it is really enabled.

Maybe I should try to load the effect from command line, it might display an error msg. I might load Configure Desktop from command line and from there get to the window behavior. Will try tonight! :slight_smile: They are not smart enough at work to use linux. lollll :stuck_out_tongue:

In KDE4:
I installed the 177.82 OEM driver
edited /etc/x11/xorg.conf to read

Section "Extensions"
  Option       "Composite" "on"

then go into Desktop Effects & tick it on
Walk through the setup & select your goodies. i.e.,
cube, etc

Make sure you have 4 desktops selected:)

Worked for me;)

Humm… weird. :\ Cube, transparency, animations, etc., these all work. Forcing an application to have a define geometry also works.

But displaying the geometry when you resize (like compiz-fusion) or move the window, that did not work.

I don’t have “Composite On”, I have “Composite Enabled”, but I think it’s the same, is it?

If I use 177.80, which aren’t the latest, then maybe they are not working fully. I will try with release version in a few days and latest drivers to see. It’s probably not a bug as it does work for you. :slight_smile:

Anybody come up with any solutions to this issue?

I’m running 11.1 (release) with stock KDE and now that I’ve installed the ‘nvidia’ driver (instead of the non-accelerated ‘nv’ default) I can’t see the window geometry information when I resize my windows either.

Other than that, everything else seems to be working as-expected, including various “Desktop Effects” like Translucency and Wobbly Windows.

I’m glad not to be the only one for this, but I didn’t find anything to have them displayed.

I wonder if I should log a bug to opensuse or nvidia or KDE…

Also not sure how to give backtrace on this. Maybe loading the simple ccsm from konsole and ticking on and off the geometry options would show something, I don’t know yet.