Display flickers unusably with 11.4 installation

Installed 11.4 on my 2005 Toshiba Sattelite Pro L10 - 1GB & P3 1.6 - and very soon after loading the display flickers erratically and blacks out or renders transparent portions of windows. Menus flicker, controls become inoperative and it is unusable. It has an Intel 855 graphics chip, desctibed in another post as a ‘linux killer’ for some reason I don’t know.

No woes with other distros on this machine, ever. I’d love to look at logs, try for an updated driver or whatever but it can’t be used. I ran the download ISO inside VMware Fusion before installing and it had no probs with that, thus it seems that the d/l is OK, at least.

Please, any solution(s) before I overwrite and dig out Ubuntu?

Consider using the nomodeset kernel load option. This command is present in the Failsafe entry. So, before you press enter, to select the normal openSUSE startup, enter the option:


And then press the enter key. If this works, you can add this as a standard kernel startup command. In KDE you can use the Run Command:

kdesu kwrite /boot/grub/menu.lst

You can edit the menu.lst file and add the nomodeset command to be used all of the time like this:

kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-INTEL_SSDSA2M080G2GC_CVPO037603KN080JGN-part1 resume=/dev/disk/by-id/ata-Hitachi_HDS721010CLA332_JP9921HD2SSJLH-part5 splash=silent **nomodeset** showopts vga=0x346

I show the nomodeset kernel load option in bold so it sticks out, but it is not in bold really. Let us know if this helps.

Thank You,

Same here on a Dell Inspiron 700m. However the display works fine when used as a remote X display, so it seems to be something to do with the desktop rather than the X server. This laptop has never needed special boot settings so I doubt if it’s nomodeset. I’d be interested to see how this pans out.

Just a guess on my part, but maybe this blog’s advice could be helpful?

Specifically for KDE4.6:

System Settings >> Startup and Shutdown >> Service Manager >> Disable ‘Display management change monitor’, then restart the desktop. See if that makes a difference.

‘nomodeset’ worked fine! Many thanks, James.

Disable ‘Display management change monitor’ : is this ‘nomodeset’ in GUI format?

‘nomodeset’ worked fine! Many thanks, James.

Disable ‘Display management change monitor’ : is this ‘nomodeset’ in GUI format?
Happy to hear of your success pofadda. That report about KDE4 was made is 2008 and is pretty old. It is hard to say if it would still apply to KDE 4.6 but deano_ferrari did determine the new way to disable the function is with *System Settings >> Startup and Shutdown >> Service Manager >> Disable ‘Display management change monitor’ *but I am inclined to stick with the nomodeset kernel load option myself. As a relative new forum user, I always add a few more things for you to look at.

Get more info on forum operation here:

openSUSE Forums FAQ

Forum Message Counts:

As you start or answer any message thread here in the openSUSE forums.

Puzzled Penguin 0-49 (new users start with this level)
Student Penguin 50-99
Explorer Penguin 100-249
Busy Penguin 250-499
Parent Penguin 500-999
Wise Penguin 1000-1999
Omniscient Penguin 2000

Here is a picture of the message count symbols:

openSUSE Forum Message Count Symbols

FYI here are the reputation levels:

You can reward another user for the help they have provided you using
the reputation icon is in the lower left of any message that you read
which looks like a star.


User is infamous around these parts -99999
User can only hope to improve -50
User has a little shameless behavior in the past -10
User is an unknown quantity at this point 0-9 (new users start with this level)
User is on a distinguished road 10-19
User will become famous soon enough 20-149
User has a spectacular aura about 150-249
User is a jewel in the rough 250-349
User is just really nice 350-449
User is a glorious beacon of light 450-549
User is a name known to all 550-649
User is a splendid one to behold 650-999
User has much to be proud of 1000-1499
User has a brilliant future 1500-1999
User has a reputation beyond repute 2000

Thank You,

Unfortunately neither solution works for me. nomodeset disables the external display and I cannot switch to it with Alt-F8 (exact key depends on computer model), so while it may fix the internal display, it’s not a workable solution for me. Turning off the Monitor display changes also has the same effect but takes effect after X has been started. Since this laptop works fine as a remote X display at the moment and I have no plans to take this machine elsewhere, I’ll just wait and see. It seems the software is confused by having two displays, one builtin and one external, that’s the situation that is different in my setup.

ken_yap, before I would give up, I would surely try kernel 2.6.38 first. Its not final yet, but rc8 is pretty close. Here is the link:


If you have never tried SAKC, please give it a try, it is simply to use, even if you know the commands by heart:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00

Message #17 has the most recent version of SAKC. What have you got to lose, but a little time?

Thank You,

I doubt if it’s the kernel. I think it’s either the desktop or the X server. There has been a regression from 11.3. And I think people are resorting to mystery workarounds instead of understanding what the problem really is. My theory is that since KDE 4.6 now has fancy translucency, the X server is advertising capabilities it really doesn’t have to the desktop.

Unfortunately time is not something I am willing to devote to this problem. It isn’t blocking my work as I’ve explained, and worst comes to the worst, I’ll revert to 11.3.But I’ll keep an eye out for more evidence.

I’d love to use this but no star appears on Chrome! Or is it just me?

It’s a ghost! Now they appear. (Where did I leave my bell, Kindle and candle?)

This (nomodeset) seems to work GREAT on my intel 865G/ICH5 motherboard … Thanks for the advice.

                 This (nomodeset) seems to work GREAT on my intel 865G/ICH5 motherboard ... Thanks for the advice.

Happy to hear the information was helpful reggieq and welcome to the openSUSE forums.

Thank You,